summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 03:50:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 03:50:03 +0200
commitd213eeca9597b6b8452ad677842683e7e890bef7 (patch)
tree262ec8f5d54e4ce413dd6b20f5ef157138755c5a /dev-python/pyproject-fmt-rust
parentdev-python/mkdocstrings-python: Bump to 1.10.1 (diff)
downloadgentoo-d213eeca9597b6b8452ad677842683e7e890bef7.tar.gz
gentoo-d213eeca9597b6b8452ad677842683e7e890bef7.tar.bz2
gentoo-d213eeca9597b6b8452ad677842683e7e890bef7.zip
dev-python/pyproject-fmt-rust: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt-rust')
-rw-r--r--dev-python/pyproject-fmt-rust/Manifest1
-rw-r--r--dev-python/pyproject-fmt-rust/pyproject-fmt-rust-1.1.0.ebuild159
2 files changed, 160 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt-rust/Manifest b/dev-python/pyproject-fmt-rust/Manifest
index 9cade297695d..07e9bf99f8a2 100644
--- a/dev-python/pyproject-fmt-rust/Manifest
+++ b/dev-python/pyproject-fmt-rust/Manifest
@@ -61,6 +61,7 @@ DIST pyo3-macros-backend-0.21.2.crate 58088 BLAKE2B 05dd49983c8aeddc47cd94f6cd58
DIST pyproject_fmt_rust-1.0.1.tar.gz 28922 BLAKE2B e2ba8580a4b64f6ae4e0608ebc9f7e7f5b7fa736b64fab199eaeed1c3e1453d4fb12c17d1e3a924191c023550b704dc6ea12fcf739c4c22f6987f952c0a3dd4d SHA512 f14629a95c22bc1469c198f90c7da80e88a82251b8a25c013748a2f0c32041cf9462ea728a5e5e440757b272d48b0396fc8fe67fe852effbfd769d50fe24f16d
DIST pyproject_fmt_rust-1.0.4.tar.gz 28896 BLAKE2B d2a8520cda6f155dc0d8090f40466f2edb72f329f3c6c22bdd6a202b09297e3160b6aa54360cb77d68b797a767a2fda08a7cb296f25c4770959f3a114a22e323 SHA512 d41d3e3cba0ec83c23071291270376ed835f05dcb7759ac4e88208c5eebd3e040b0226aa833fdf3ca25e60ddb6c3a932196e30d51ddca05771b6e20440d1406c
DIST pyproject_fmt_rust-1.0.6.tar.gz 29264 BLAKE2B 1d3e2636f09b376590450573d9e7c6e2892b8d495674e08af5a84f7a08cd644550f5fa4d2c3133286b38086a6c08d335a0b3cb67bf6bbaf1a139f21fafc7cb2c SHA512 cca3244d63f5082bf3f3b54982af2f5b0a0bba5c5e768552a3f079fa647a5aa9682038fec0ee55ff6c67efaa13e728d74821dee6229a6217bdf6ab055b887c70
+DIST pyproject_fmt_rust-1.1.0.tar.gz 32970 BLAKE2B 57b35294ab4fd84d13c76463f7b6461169c6e661a9e456d6955d9226d7bbd85293e96a6838fa126af36ac135a5323a6d3009d2c9444eaa76f654f8b158cf4802 SHA512 ccead88b5d31fc00e1c51296d79846146da4804702824da65dec2b5b85a83deac82cf70101f91bf52c9e5228cac16dafb8556bdca95efcc96c6fe1f02d94cf3e
DIST quote-1.0.36.crate 28507 BLAKE2B b93495163ed205e33543ed45f084870240d479071d643704b6e348fb9ada6e1d8401893c13348b9964f4b6b17ddb96cb5458eec540f0d761655fcb96a4cd9129 SHA512 f1f002a912692f7ffd4912ca980ec57ff4aca3a7d9e2e42e9e3409e2105c9f59d86c05719f6af309bccaef2f8843b0848a6e3afda3356e045d8e7cc5956ae685
DIST redox_syscall-0.4.1.crate 24858 BLAKE2B c3301137a0b84e03b09d28dfa377ab3bea74d574a08cee21d35713b278d8b5b30ca2a1d73a0981baeb4644cbb88c86c8eb15ab3bb2692e38b93e6b35fab4e0da SHA512 073ed9d96090cf46eab9877742277a013c62d8da86d9caf2310b4fa868af306511936553579e01309f27067d344226cc8dc5e3aef01d9b900da2febd33848f8d
DIST regex-1.10.4.crate 253191 BLAKE2B 08bdb925efbea1ee9f885a89ec6b4692e39d7b17039f788e5b3c1dbfb7847d4f53b67f0c61e4085af7ef4901e67e33ea94948668bf706fef19b4102a06ef0447 SHA512 88ef121a51759f418d5dc01607a6e02651bd00343dae92962c02a80f30343d3f079a0375457780ce46bf205ca38f279b03989154638199fe2fcede10554bf21b
diff --git a/dev-python/pyproject-fmt-rust/pyproject-fmt-rust-1.1.0.ebuild b/dev-python/pyproject-fmt-rust/pyproject-fmt-rust-1.1.0.ebuild
new file mode 100644
index 000000000000..1255b5969e06
--- /dev/null
+++ b/dev-python/pyproject-fmt-rust/pyproject-fmt-rust-1.1.0.ebuild
@@ -0,0 +1,159 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=maturin
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+CRATES="
+ ahash@0.8.11
+ aho-corasick@1.1.3
+ any_ascii@0.1.7
+ arc-swap@1.7.1
+ autocfg@1.2.0
+ beef@0.5.2
+ bitflags@1.3.2
+ bstr@1.9.1
+ cfg-if@1.0.0
+ countme@3.0.1
+ deranged@0.3.11
+ derivative@2.2.0
+ either@1.11.0
+ fnv@1.0.7
+ form_urlencoded@1.2.1
+ futures-channel@0.3.30
+ futures-core@0.3.30
+ futures-executor@0.3.30
+ futures-io@0.3.30
+ futures-macro@0.3.30
+ futures-sink@0.3.30
+ futures-task@0.3.30
+ futures-timer@3.0.3
+ futures-util@0.3.30
+ futures@0.3.30
+ getrandom@0.2.14
+ glob@0.3.1
+ globset@0.4.14
+ hashbrown@0.14.3
+ heck@0.4.1
+ idna@0.5.0
+ indoc@2.0.5
+ itertools@0.10.5
+ itoa@1.0.11
+ lexical-sort@0.3.1
+ libc@0.2.153
+ lock_api@0.4.11
+ log@0.4.21
+ logos-derive@0.12.1
+ logos@0.12.1
+ memchr@2.7.2
+ memoffset@0.9.1
+ num-conv@0.1.0
+ once_cell@1.19.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.9
+ pep440_rs@0.6.0
+ pep508_rs@0.6.0
+ percent-encoding@2.3.1
+ pin-project-lite@0.2.14
+ pin-utils@0.1.0
+ portable-atomic@1.6.0
+ powerfmt@0.2.0
+ proc-macro2@1.0.81
+ pyo3-build-config@0.21.2
+ pyo3-ffi@0.21.2
+ pyo3-macros-backend@0.21.2
+ pyo3-macros@0.21.2
+ pyo3@0.21.2
+ quote@1.0.36
+ redox_syscall@0.4.1
+ regex-automata@0.4.6
+ regex-syntax@0.6.29
+ regex-syntax@0.8.3
+ regex@1.10.4
+ relative-path@1.9.2
+ rowan@0.15.15
+ rstest@0.19.0
+ rstest_macros@0.19.0
+ rustc-hash@1.1.0
+ rustc_version@0.4.0
+ ryu@1.0.17
+ scopeguard@1.2.0
+ semver@1.0.22
+ serde@1.0.198
+ serde_derive@1.0.198
+ serde_json@1.0.116
+ slab@0.4.9
+ smallvec@1.13.2
+ syn@1.0.109
+ syn@2.0.60
+ taplo@0.13.0
+ target-lexicon@0.12.14
+ text-size@1.1.1
+ thiserror-impl@1.0.59
+ thiserror@1.0.59
+ time-core@0.1.2
+ time-macros@0.2.18
+ time@0.3.36
+ tinyvec@1.6.0
+ tinyvec_macros@0.1.1
+ tracing-attributes@0.1.27
+ tracing-core@0.1.32
+ tracing@0.1.40
+ unicode-bidi@0.3.15
+ unicode-ident@1.0.12
+ unicode-normalization@0.1.23
+ unicode-width@0.1.12
+ unindent@0.2.3
+ unscanny@0.1.0
+ url@2.5.0
+ urlencoding@2.1.3
+ version_check@0.9.4
+ wasi@0.11.0+wasi-snapshot-preview1
+ windows-targets@0.48.5
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_msvc@0.48.5
+ windows_i686_gnu@0.48.5
+ windows_i686_msvc@0.48.5
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_msvc@0.48.5
+ zerocopy-derive@0.7.32
+ zerocopy@0.7.32
+"
+
+inherit cargo distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file (Rust extension)"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt-rust/
+ https://pypi.org/project/pyproject-fmt-rust/
+"
+SRC_URI+="
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0-with-LLVM-exceptions ISC MIT Unicode-DFS-2016
+ || ( Apache-2.0 BSD-2 )
+ || ( Apache-2.0 Boost-1.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib/py.*/site-packages/pyproject_fmt_rust/_lib.*.so"
+
+src_prepare() {
+ sed -i -e '/strip/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test_all() {
+ cargo_src_test
+}