summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-01-24 18:23:15 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-09 15:57:54 +0200
commit07f32da91e9b4d879118ee228e484a319257dbe7 (patch)
tree39152e9717eedee3dfa2d29e8be6a4f7cf07433a /dev-python/pyroute2
parentx11-themes/vanilla-dmz-xcursors: Correct description (diff)
downloadgentoo-07f32da91e9b4d879118ee228e484a319257dbe7.tar.gz
gentoo-07f32da91e9b4d879118ee228e484a319257dbe7.tar.bz2
gentoo-07f32da91e9b4d879118ee228e484a319257dbe7.zip
dev-python/pyroute2: add 0.7.11
Temporarily switch to github instead of pypi for SRC_URI. This release was not pushed to pypi in source form. Related-to: https://github.com/svinota/pyroute2/issues/1162 Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/34991 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.11.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index 56aa91bece19..3e0d24d6e701 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.7.10.tar.gz 422192 BLAKE2B ee3eb0961537427aa8ec22d38b0e7e2f53f0ce0fe6802ded685fff1b91616b712b014d64b418122d98a29c030021a7414d2a0f71eff7afaa6e15cc432772c503 SHA512 834beeffb7d5436db6668217d3c3593798727996858211ff5a582446be095372a0c979c328ac97fd1485c27b0b56aedf256fc9ff5c74d2ef9665dce09fbd042d
+DIST pyroute2-0.7.11.gh.tar.gz 502687 BLAKE2B 8874c8a08e24420f0f53cdcfa0d4a67ce51b6650aaf90e9df8a544e6cb50940ee020ad3a377775a1ea2ddf8824df5e9888766e5239c6dcf459a3a2bd32825612 SHA512 1390aee45fe1cafd13d2e971102321f798e6f6952b0d1c805eb3258d9b55bd442ffcf36682c285c4a75deb8bc6109ea933721986eb4cae09f7962fadc3eb9070
diff --git a/dev-python/pyroute2/pyroute2-0.7.11.ebuild b/dev-python/pyroute2/pyroute2-0.7.11.ebuild
new file mode 100644
index 000000000000..1c5c1b6448bd
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2/
+ https://pypi.org/project/pyroute2/
+"
+
+SRC_URI="https://github.com/svinota/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"