summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-04 01:45:29 -0500
committerSam James <sam@gentoo.org>2024-02-04 20:10:37 +0000
commit5dedeb12e830676033a4501ad95a72ec7cc0b7d9 (patch)
treeb6a9d7bd8c2e70170403a5e2b06627461d9fae0f /dev-python/pyroute2
parentdev-util/yamllint: remove never-correct dependency on setuptools (diff)
downloadgentoo-5dedeb12e830676033a4501ad95a72ec7cc0b7d9.tar.gz
gentoo-5dedeb12e830676033a4501ad95a72ec7cc0b7d9.tar.bz2
gentoo-5dedeb12e830676033a4501ad95a72ec7cc0b7d9.zip
dev-python/pyroute2: drop outdated runtime dependency on setuptools
Removed upstream in 0.5.10 via commit: https://github.com/svinota/pyroute2/commit/7d1a19c60aeceb3851413dcdcd547ee2f254bc11 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild b/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild
new file mode 100644
index 000000000000..5450ffde31c0
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2/
+ https://pypi.org/project/pyroute2/
+"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"