summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 17:16:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 17:22:56 +0200
commit92662257dfed4b16e9fefcd30349b46d63db792c (patch)
tree53a5eef170510a0b7b22a5f89733548775f415d8 /dev-python/pysmi
parentdev-python/pykerberos: EAPI 8, PEP517 (diff)
downloadgentoo-92662257dfed4b16e9fefcd30349b46d63db792c.tar.gz
gentoo-92662257dfed4b16e9fefcd30349b46d63db792c.tar.bz2
gentoo-92662257dfed4b16e9fefcd30349b46d63db792c.zip
dev-python/pysmi: EAPI 8, PEP517
Closes: https://bugs.gentoo.org/909944 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pysmi')
-rw-r--r--dev-python/pysmi/pysmi-0.3.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pysmi/pysmi-0.3.4-r1.ebuild b/dev-python/pysmi/pysmi-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..22bf1f08d3dc
--- /dev/null
+++ b/dev-python/pysmi/pysmi-0.3.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2017-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Lex & Yacc"
+HOMEPAGE="
+ https://github.com/etingof/pysmi/
+ https://pypi.org/project/pysmi/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pysnmp[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs/source