summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-13 16:35:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-13 16:58:25 +0200
commitefa85dd0615e304ed8e2bff310c0cae52b4bec93 (patch)
tree3a18f556e426bf43c05e17df14327961cdb452b0 /dev-python/pysnmp
parentdev-python/pyfakefs: Bump to 5.7.1 (diff)
downloadgentoo-efa85dd0615e304ed8e2bff310c0cae52b4bec93.tar.gz
gentoo-efa85dd0615e304ed8e2bff310c0cae52b4bec93.tar.bz2
gentoo-efa85dd0615e304ed8e2bff310c0cae52b4bec93.zip
dev-python/pysnmp: Bump to 7.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pysnmp')
-rw-r--r--dev-python/pysnmp/Manifest1
-rw-r--r--dev-python/pysnmp/pysnmp-7.1.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pysnmp/Manifest b/dev-python/pysnmp/Manifest
index 3efc301f8f4f..a5319de25a0a 100644
--- a/dev-python/pysnmp/Manifest
+++ b/dev-python/pysnmp/Manifest
@@ -1,2 +1,3 @@
DIST pysnmp-7.0.3.tar.gz 427830 BLAKE2B 5855095c40ca63bfb705293d33d061d94ad0958ab854863fb73468d6aee846ea2fd843f4444eb93a29cb8c1ec3043e1d90445628e66392b04d43d2c027c4ce79 SHA512 9c23ab7073b40ae43a6c56b81c05ef6639f99f44153dcb2f97a455402495cfb5dc8f70025331d5461e6e18a66e1de8246506947bc80465df67cba2381d0d891d
DIST pysnmp-7.1.5.tar.gz 329154 BLAKE2B e4befd3a4e9dcbd777feff76af4df474952c7c91e787b43247e15ab32da162c9ea6ea4c56d059af811872b0119e6acc912a8c44c5efb96181db861589abaa2df SHA512 61a462c62c27a65c62a33ebb8d1f92efc1dd3284785ab8cdc3b0073d92d2aada2a0dea55629a7ea99ca181a30585cb729d994169fc2b6d4d029630cefff2648d
+DIST pysnmp-7.1.6.tar.gz 345379 BLAKE2B e2baae9150561634a0408ffd8d4173106aff18f59f165ee178cd20359b070561debc5706da2092e38aee1772f8c035b0156625234d96596028ac7f0644dc76f5 SHA512 40fe86942e44586c3192ca0e99b8970011e3d573765e8b301a2fedece64acc99cadc5d47e389dab3341d8d26825df524484401509bbdc1e55a1835e6fee15290
diff --git a/dev-python/pysnmp/pysnmp-7.1.6.ebuild b/dev-python/pysnmp/pysnmp-7.1.6.ebuild
new file mode 100644
index 000000000000..97044728012a
--- /dev/null
+++ b/dev-python/pysnmp/pysnmp-7.1.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python SNMP library"
+HOMEPAGE="
+ https://pypi.org/project/pysnmp/
+ https://github.com/lextudio/pysnmp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/cryptography-43.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/pysmi-1.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO
+# distutils_enable_sphinx docs/source dev-python/furo dev-python/sphinx-copybutton dev-python/sphinx-sitemap
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ mibdump NET-SNMP-EXAMPLES-MIB || die
+ mibdump IF-MIB || die
+ epytest -p asyncio
+}