summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-14 21:07:35 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-14 21:22:01 -0500
commitb7543c7ba0b3dea0002a027777a125fa4944cda2 (patch)
tree9a0025bf86c935b11ef5dab29e47e1fe3f21c947 /dev-python/pytest-bdd
parentdev-python/gherkin-official: new package, add 30.0.3 (diff)
downloadgentoo-b7543c7ba0b3dea0002a027777a125fa4944cda2.tar.gz
gentoo-b7543c7ba0b3dea0002a027777a125fa4944cda2.tar.bz2
gentoo-b7543c7ba0b3dea0002a027777a125fa4944cda2.zip
dev-python/pytest-bdd: add 8.0.0
Nothing need this at the moment given it breaks its only revdep (qutebrowser) with a long list of parsing errors (being updated to require <8 for now). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-8.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 95ffdaf0b8c9..40828bf7b681 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1 +1,2 @@
DIST pytest-bdd-7.3.0.gh.tar.gz 81595 BLAKE2B 80c5323ba3c50fae17bb57ec26b968ca7d7b673d2aeb2716dee02e3543916ca8b5752d9af56d3d250f3a4b0a857a3dc760de615f0650eaf379380fb24a5b7c2a SHA512 e7c309552714a77d47e437a825e661dbf201a6945e84f4b611b5c3da3d0b4ceb535bde4809fc9633b82a74e2b52cc69c7e14b27a27032c7e4400727498442e29
+DIST pytest-bdd-8.0.0.gh.tar.gz 113480 BLAKE2B 142346b449199bb619fce9da199c64cc0678366ca5344979246cf45cb99c3039af5ac32f42b9fe2e46c60a70d204b50e14da53441a047d7156f8f9fc21cf0d95 SHA512 18d369aa38765a1d543e63de4477155be68d75954eef8908cac2898afe89dee3c9fb36ee667de39c53d2f0d637d4f343b31970c2d75faccdd53eaf952ebdf55f
diff --git a/dev-python/pytest-bdd/pytest-bdd-8.0.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-8.0.0.ebuild
new file mode 100644
index 000000000000..6432d5b40519
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-8.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pytest-bdd.readthedocs.io/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/gherkin-official[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/parse-type[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}