summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-23 15:07:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-23 15:56:45 +0100
commit68ac981a6ec2ad91072cd4aba96492c680b33e7c (patch)
treeac5764f81e876a0d7da87be67fac4ce18e7143c9 /dev-python/pytest-cov
parentsys-libs/tevent: add missing `#include <sys/types.h>` (diff)
downloadgentoo-68ac981a6ec2ad91072cd4aba96492c680b33e7c.tar.gz
gentoo-68ac981a6ec2ad91072cd4aba96492c680b33e7c.tar.bz2
gentoo-68ac981a6ec2ad91072cd4aba96492c680b33e7c.zip
dev-python/pytest-cov: Backport test fix for coverage-6.2
Closes: https://bugs.gentoo.org/823766 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-3.0.0-coverage-6.2.patch30
-rw-r--r--dev-python/pytest-cov/pytest-cov-3.0.0.ebuild7
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/pytest-cov/files/pytest-cov-3.0.0-coverage-6.2.patch b/dev-python/pytest-cov/files/pytest-cov-3.0.0-coverage-6.2.patch
new file mode 100644
index 000000000000..b44326d8b60d
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-3.0.0-coverage-6.2.patch
@@ -0,0 +1,30 @@
+From 6d06678a76d9275beb48917d7653ea6a610c7717 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 23 Jan 2022 15:03:35 +0100
+Subject: [PATCH] Update test_invalid_coverage_source for coverage-6.2
+
+Update test_invalid_coverage_source to make the "No data was collected"
+less strict, as the output has changed in coverage-6.2. This solution
+was suggested by Tom Callaway (@spotrh) on the linked bug.
+
+Fixes #509
+---
+ tests/test_pytest_cov.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
+index f93d352..6d97949 100644
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -981,7 +981,7 @@ def test_invalid_coverage_source(testdir):
+ '*10 passed*'
+ ])
+ result.stderr.fnmatch_lines([
+- 'Coverage.py warning: No data was collected.*'
++ '*No data was collected.*'
+ ])
+ result.stdout.fnmatch_lines([
+ '*Failed to generate report: No data to report.',
+--
+2.34.1
+
diff --git a/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
index 4d424eac1bdd..db4782be9764 100644
--- a/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,6 +36,11 @@ distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/pytest-dev/pytest-cov/pull/518
+ "${FILESDIR}"/${P}-coverage-6.2.patch
+)
+
EPYTEST_DESELECT=(
# attempts to install packages via pip (network)
tests/test_pytest_cov.py::test_dist_missing_data