summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-29 04:46:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-29 04:46:53 +0200
commitfcc4d76ffa6919da2b797c5e6635c56625308248 (patch)
tree36b0349d7baddea417567a66d76eec52c75ff576 /dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
parentdev-python/aws-sam-translator: Bump to 1.72.0 (diff)
downloadgentoo-fcc4d76ffa6919da2b797c5e6635c56625308248.tar.gz
gentoo-fcc4d76ffa6919da2b797c5e6635c56625308248.tar.bz2
gentoo-fcc4d76ffa6919da2b797c5e6635c56625308248.zip
dev-python/pytest-param-files: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild')
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
new file mode 100644
index 000000000000..5982d88730fe
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest