summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-11 08:37:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-11 09:06:10 +0200
commit5776437cacce55e51848438f5b8ebd4bdeaee76d (patch)
tree6e86d9827fd053353df26eccd4be4782e3e39524 /dev-python/pytest-sugar
parentdev-python/pyspnego: Bump to 0.5.3 (diff)
downloadgentoo-5776437cacce55e51848438f5b8ebd4bdeaee76d.tar.gz
gentoo-5776437cacce55e51848438f5b8ebd4bdeaee76d.tar.bz2
gentoo-5776437cacce55e51848438f5b8ebd4bdeaee76d.zip
dev-python/pytest-sugar: Bump to 0.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-sugar')
-rw-r--r--dev-python/pytest-sugar/Manifest1
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/Manifest b/dev-python/pytest-sugar/Manifest
index 69354e873cf4..f69d56569e43 100644
--- a/dev-python/pytest-sugar/Manifest
+++ b/dev-python/pytest-sugar/Manifest
@@ -1 +1,2 @@
DIST pytest-sugar-0.9.4.tar.gz 12727 BLAKE2B 898692fc4083871d707fad44c7dd0c1298c28c190d705ef4525d4ba68d77bd37bb2634e43795ea553041317dc2f014d9be8ef52cfe40383ee75af36e5780cb98 SHA512 bbe375f0ae934d132457d698c9e09994a9a96a31860397f1b5e50b32139e5018f0137ddc0d3dd84bec29fc2b4c16592f59a38933c53fb8acec714c64689c4c76
+DIST pytest-sugar-0.9.5.tar.gz 13545 BLAKE2B 37c5241b951b3167c73537ca7bbb93f679673e57c84a13b74caacfcb8d5510b5e5ad215aa4aa33f722efffa54d30ff73d521bce412214857d11c25c255596bdc SHA512 4451d09181b6130591c504b2825a86777f5daa6972a6be7f2bc51139cf3ef2e57dfc1b8ea1972220a1c84866ed2584c684cc83c8052cb9105c0c3a9ea19922fe
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.5.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.5.ebuild
new file mode 100644
index 000000000000..87ea2427d002
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that changes the default look and feel of py.test"
+HOMEPAGE="
+ https://github.com/Teemu/pytest-sugar/
+ https://pypi.org/project/pytest-sugar/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest