summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-01 11:06:31 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-01 12:02:19 +0100
commitfa6dfe4349d8e1f650d954026ac2a288909a8676 (patch)
tree7b2dd8b9ea2e647488332c81cff347778c4d3b80 /dev-python/pytest-testinfra
parentdev-python/pyopencl: bump to 2021.2.5 and EAPI 8 (diff)
downloadgentoo-fa6dfe4349d8e1f650d954026ac2a288909a8676.tar.gz
gentoo-fa6dfe4349d8e1f650d954026ac2a288909a8676.tar.bz2
gentoo-fa6dfe4349d8e1f650d954026ac2a288909a8676.zip
dev-python/pytest-testinfra: bump to 6.4.0 and EAPI 8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 37bc260fa2e1..6299db7974bf 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1 +1,2 @@
DIST pytest-testinfra-6.3.0.tar.gz 76309 BLAKE2B 95b4a6ac5ea3c3db2afdd537209bfeb2c188ec7c7935b73e831733fbbf2540b8769d1187338b3b9c9da997cd653e800004e7199537d95530967cd73a15cb2c2e SHA512 ff0add6bdadac92f6f997a94734d69d39598bc8d1f7689a6b269e59bc886825fcf8a42968c2d34a9ad7e77ed0112bf4044afede8e0dca2bbddc76c9c5612ae92
+DIST pytest-testinfra-6.4.0.tar.gz 77516 BLAKE2B 2baf5940e8736cbe78d8017a82b3a8fdb6df95b89acccd49ecd354447b7ea88079f48211e0acea46a0d8702b67609fe6f85f730c66e781a99d8a92b52b3c99b9 SHA512 acd2c7f9daeb391815a32c972a3542c0d643a716f3cffcb66f4203435ebac789333edb91c83d2778ae8da93b676b245fd47821bca9218faa3e7b50e6764087f4
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild
new file mode 100644
index 000000000000..c336646d0373
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# Ansible is called via its CLI
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}