summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-24 10:21:25 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-28 10:33:00 -0500
commit63c071c399e56077578a29fce729effbba0e774c (patch)
tree2d15a856890cd3e55903a3d82ac4cbb2398b9dab /dev-python/pytest
parentdev-python/docker-py: remove old (diff)
downloadgentoo-63c071c399e56077578a29fce729effbba0e774c.tar.gz
gentoo-63c071c399e56077578a29fce729effbba0e774c.tar.bz2
gentoo-63c071c399e56077578a29fce729effbba0e774c.zip
dev-python/pytest: remove 2.7.2
Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-2.7.2.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index c0ed6a1dea71..5fd8a3685ed3 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,3 +1,2 @@
-DIST pytest-2.7.2.tar.gz 532836 BLAKE2B abdb179ca82078ecf081055484d7fc1f1d63f7f3ce58b19ed27e10da25e163a24ad89e4afe8b7e5af0d5fa14ace6eb18c6dbe302845fb6bbf0a545a443fc7847 SHA512 5474a4fe58437a4971fb21b1b37dad3c08e18e5d154931ff23e597f881100a3515bf0cf71d06b143465594ad2a91a96f84f4836d84c39691143c8d88ca7a4360
DIST pytest-3.0.3.tar.gz 731934 BLAKE2B 7fb57d75bd54eb8a31d9701fdf739119715c475eaaacae3cd038057c1d2bf43fa86ccdc45b3c84962708ef606976ab39ad41e0c3690c8b5f4c04d870579a384e SHA512 ec0b4a5f0d6673a339c5a70b402c004c23db7001005454329eeaea15d890f53b8f2740f6c6254499d0f915b9058bfdfa535d9f22847bb382a060d65204fce4af
DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e74655f7b4cb08ec421651f987597021a31471aab5a32d637b99620ce7792cbdf8f85561db3bb10ff06a446ba1 SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db
diff --git a/dev-python/pytest/pytest-2.7.2.ebuild b/dev-python/pytest/pytest-2.7.2.ebuild
deleted file mode 100644
index ce6683f5f930..000000000000
--- a/dev-python/pytest/pytest-2.7.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.29"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Prevent un-needed d'loading
- sed -e "s/'sphinx.ext.intersphinx', //" -i doc/en/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- # test_nose.py not written to suit py3.2 in pypy3
- if [[ "${EPYTHON}" == pypy3 ]]; then
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- --ignore=testing/test_nose.py \
- || die "tests failed with ${EPYTHON}"
- else
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- || die "tests failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && dohtml -r doc/en/_build/html/
- distutils-r1_python_install_all
-}