summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 19:14:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 19:14:24 +0100
commit168998ef78e9c6bca26cecb9f2deb34ae90e3577 (patch)
tree4bd2875f540ba5e7a63bd768547e2929f7934c23 /dev-python/python-cinderclient
parentdev-python/python-keystoneclient: EAPI 8, PEP517, py3.10 (diff)
downloadgentoo-168998ef78e9c6bca26cecb9f2deb34ae90e3577.tar.gz
gentoo-168998ef78e9c6bca26cecb9f2deb34ae90e3577.tar.bz2
gentoo-168998ef78e9c6bca26cecb9f2deb34ae90e3577.zip
dev-python/python-cinderclient: PEP517, py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild
new file mode 100644
index 000000000000..285508bda622
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}