summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 17:56:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 19:51:29 +0100
commit4dcefef12bb92dbadec4f01dec21020acdb42cf3 (patch)
tree25658aa75969a760824e49bf44afc6ab50dc1b78 /dev-python/python-cinderclient
parentmedia-radio/fldigi: add 4.1.24 (diff)
downloadgentoo-4dcefef12bb92dbadec4f01dec21020acdb42cf3.tar.gz
gentoo-4dcefef12bb92dbadec4f01dec21020acdb42cf3.tar.bz2
gentoo-4dcefef12bb92dbadec4f01dec21020acdb42cf3.zip
dev-python/python-cinderclient: Bump to 9.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 3230106a1691..b198ccd6a879 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1 +1,2 @@
DIST python-cinderclient-9.2.0.tar.gz 235773 BLAKE2B 1b4e1c27dec6d74a2c95e3aadbdfb296bf6105ba5a23599babfcf8fc5c37fb52eecf7897eaa0680277b903b1725de2cb7d9a108942fa1be5067b25dce8ca0c72 SHA512 76032779bfa2dbc6c7aecc6631ab42b80bff21437d5037e6bbc5d78a23ce493a7a185c4ee8c1657b41c0bf376a6c919b027f81577f2826fc4222334d8216fda5
+DIST python-cinderclient-9.3.0.tar.gz 236158 BLAKE2B 7f21485e907597de77ba9998e190c4ea05d3b968fb1886bd980e5f15addf26b35acf096c2c3b28e6d05d95125dbd568362ce500ff8643da27baa45b165f5e105 SHA512 3e8b957517a394f2b72cfb8f3442d8b57d4487be476e10f16c112134c1e5a8548056ce0a0cf75cac55d8a607e34e535593130f25aa413c86adf301465112dbb2
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.3.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.3.0.ebuild
new file mode 100644
index 000000000000..8c820686265d
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-9.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-cinderclient/
+ https://github.com/openstack/python-cinderclient/
+ https://pypi.org/project/python-cinderclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+# Tests fail with dev-python/prettytable-3.4.0
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ <dev-python/prettytable-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}