summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-06 09:39:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-06 09:39:52 +0300
commitb3be3aa0686a5c192b4f9c1f28c52fc45a970658 (patch)
treee1e7e69dce4c3fc58d22c0d5e86628dd1513a645 /dev-python/python-daemon
parentsci-physics/root: version bump to 6.24.06 (diff)
downloadgentoo-b3be3aa0686a5c192b4f9c1f28c52fc45a970658.tar.gz
gentoo-b3be3aa0686a5c192b4f9c1f28c52fc45a970658.tar.bz2
gentoo-b3be3aa0686a5c192b4f9c1f28c52fc45a970658.zip
dev-python/python-daemon: fix testing without coverage
Also fix for >=testtools-3.5.0 Closes: https://bugs.gentoo.org/743781 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild (renamed from dev-python/python-daemon/python-daemon-2.3.0.ebuild)11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/python-daemon/python-daemon-2.3.0.ebuild b/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
index dd172f9cc2ec..ebd89363d0b2 100644
--- a/dev-python/python-daemon/python-daemon-2.3.0.ebuild
+++ b/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..9} pypy3 )
inherit distutils-r1
@@ -29,4 +29,11 @@ BDEPEND="
)
"
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fix for >=testtools-2.5.0
+ sed -e 's/testtools.helpers.safe_hasattr/hasattr/' \
+ -i test/test_metadata.py || die
+ distutils-r1_src_prepare
+}