summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-22 08:34:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-22 09:06:55 +0100
commit9f14ec33e435d116ce44622d0a2e4ce6d4595f9f (patch)
tree554220f3cb2b02a6762fe225c7d278fe59addaa5 /dev-python/python-dbusmock
parentdev-python/python-dbusmock: Remove old (diff)
downloadgentoo-9f14ec33e435d116ce44622d0a2e4ce6d4595f9f.tar.gz
gentoo-9f14ec33e435d116ce44622d0a2e4ce6d4595f9f.tar.bz2
gentoo-9f14ec33e435d116ce44622d0a2e4ce6d4595f9f.zip
dev-python/python-dbusmock: Bump to 0.34.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index efa4473c765b..84eb6ac8a78e 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1 +1,2 @@
DIST python-dbusmock-0.33.0.tar.gz 105903 BLAKE2B 5a101e64d5eff70e7a32d21080cd0051fd5617c8d057fe1cbe465903eda419fab9d0e720b0c72bac2c856d9a1371493c9b01d07ec144c2a847b6c44b65f6dd3c SHA512 419f09a5bfeab4e914c809546f3dc3bd294844116f7f0cd4a6a0b4121493c64fe6587647866323f74ed2818d1d6b45d417e384ea54c6d1244233b2a7b0d8d97d
+DIST python_dbusmock-0.34.1.tar.gz 111561 BLAKE2B 933b09ea2a679831894432bcd2e74804c3b8e7023d924512eccfdab40165f99736f85a27dd98accc2d97e36e546729fff4954eb913f7d3f5293aa50ba9326620 SHA512 093b5dec4b6f9d70b480046320211beca02e83cd0bc077448bb5329d888634805e4e6dfac9d1665b4c1ee5a15c1cec613a530443954cb4676b7a025c52bf457f
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild
new file mode 100644
index 000000000000..c61d864e5070
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-power/upower
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # tests are fragile to long socket paths
+ local -x TMPDIR=/tmp
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}