summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-18 07:18:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-18 08:47:10 +0200
commit9492689b8ba2224d162db45b6b784f1a744714de (patch)
treef43d9808b5cec9acddf5a553bbd953655d1ca438 /dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild
parentdev-python/oslo-utils: Bump to 5.0.0 (diff)
downloadgentoo-9492689b8ba2224d162db45b6b784f1a744714de.tar.gz
gentoo-9492689b8ba2224d162db45b6b784f1a744714de.tar.bz2
gentoo-9492689b8ba2224d162db45b6b784f1a744714de.zip
dev-python/python-distutils-extra: Bump to 2.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild')
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild
new file mode 100644
index 000000000000..d00792e6360e
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/
+ https://launchpad.net/python-distutils-extra/
+"
+SRC_URI="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-util/intltool
+ )
+"
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}