summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-22 13:38:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-22 14:05:11 +0100
commitd6cf8553d8b333ab225f5d52b5a94eef69f90e5f (patch)
treeba5c437ed2b46b9b8144c245d5be98b1a6ebcd0d /dev-python/rapidfuzz
parentmedia-gfx/libimagequant: Stabilize 2.18.0 ppc64, #927508 (diff)
downloadgentoo-d6cf8553d8b333ab225f5d52b5a94eef69f90e5f.tar.gz
gentoo-d6cf8553d8b333ab225f5d52b5a94eef69f90e5f.tar.bz2
gentoo-d6cf8553d8b333ab225f5d52b5a94eef69f90e5f.zip
dev-python/rapidfuzz: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rapidfuzz')
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.6.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 571d9c165612..853553bfcd59 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,2 +1 @@
-DIST rapidfuzz-3.6.1.tar.gz 1559239 BLAKE2B 50d2b2f1b1a62ad1a0a4a2300977d990a484f0a8033da6dd37531a5b603c0b28fe9a1a0e590ca9dc96bd57412864b50cf7694529127e9d26f5ef35daca6c0786 SHA512 17b40c9c3f94277340568f32ef121b277882e9191ad445df930cb394adb47bc4207008932550e74990af0d284c7af00e8ea3003114113a109a629117ebd9859c
DIST rapidfuzz-3.6.2.tar.gz 1556623 BLAKE2B aef59f1d03309535015e0fb27688613630c0e2c459f464223d4ef8dbbb0241f991ae2b9c9d81890f7cd063f33ad7e6193a6f9c98c5287010402b402e1f343b1e SHA512 83ba27ec1c68d10c568ee629519709113aac3136e73da55d46dcfd3b0f1eac2ebe8631376ca10d2b5fde892d690d79f5a8ce5fd0114502d1f3576756b0960db7
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.6.1.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.6.1.ebuild
deleted file mode 100644
index cafb2e61a8d5..000000000000
--- a/dev-python/rapidfuzz/rapidfuzz-3.6.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
-HOMEPAGE="
- https://github.com/maxbachmann/RapidFuzz/
- https://pypi.org/project/rapidfuzz/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# all these are header-only libraries
-DEPEND="
- >=dev-cpp/taskflow-3.0.0
- >=dev-cpp/rapidfuzz-cpp-3.0.0
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
- # remove bundled libraries
- rm -r extern || die
- # force recythonization
- find src -name '*.cxx' -delete || die
-
- distutils-r1_src_prepare
-
- export RAPIDFUZZ_BUILD_EXTENSION=1
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # scikit-build is broken and reuses the same build
- # https://github.com/scikit-build/scikit-build/issues/633
- rm -r _skbuild || die
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
-}