summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 09:42:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 09:54:44 +0100
commit4470b680fe2fc5e8434c34eef03dbb825e0afdff (patch)
tree27f495be78dc6f92a48664b5b09720b110230ff9 /dev-python/redis-py
parentwww-servers/tomcat: bump to 8.5.84, added verify-sig (diff)
downloadgentoo-4470b680fe2fc5e8434c34eef03dbb825e0afdff.tar.gz
gentoo-4470b680fe2fc5e8434c34eef03dbb825e0afdff.tar.bz2
gentoo-4470b680fe2fc5e8434c34eef03dbb825e0afdff.zip
dev-python/redis-py: Bump to 4.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-4.3.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index dfc9dc11274d..2ef1e6457b14 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1 +1,2 @@
DIST redis-py-4.3.4.gh.tar.gz 4613714 BLAKE2B cea5a6455160c67c9ab3b8f9de8ae47aed97e7bea1e408ce1a001afe3e0c4a7a14220887504fa40c749d15be9d89f77e36b6f7a785e0ff22a49037b6ef245e87 SHA512 55dd00c15cedb82cb5edd46b1f18f32c0accb8c85b1b94bbfe04591dc07f6151ced81cbfca8ac6fe88a6743bf5abc50309ea23bef96bf4332a712979c61ea0b7
+DIST redis-py-4.3.5.gh.tar.gz 4620696 BLAKE2B 2eaa40fc0ad624c4b8444054dcfea70ba1a2a54aaa54954f0c0fab31b310d67ca25e7508bc3550a0033139bb36bb63ddea97bb807c91ca92df3630a5385d6ba5 SHA512 42ef903f07b818061aeaea5d7d188e058db1ef73275b731cfff762fb59cb91db708ad81b0b2773cf6e0ef200ecbb3bf9859f51c4fbeb04023547b9eac4e2e042
diff --git a/dev-python/redis-py/redis-py-4.3.5.ebuild b/dev-python/redis-py/redis-py-4.3.5.ebuild
new file mode 100644
index 000000000000..5be327fc0a51
--- /dev/null
+++ b/dev-python/redis-py/redis-py-4.3.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ <dev-db/redis-7
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ )
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ # "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}