summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:17:07 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:17:07 -0600
commit775c1ade4269bcf8a20e2fe6a11068177161c4de (patch)
treee88c519277f3b4d3a2a7cb6f82e1bea72dab6c31 /dev-python/reno
parentdev-python/openstackdocstheme: 1.18.1 bup (diff)
downloadgentoo-775c1ade4269bcf8a20e2fe6a11068177161c4de.tar.gz
gentoo-775c1ade4269bcf8a20e2fe6a11068177161c4de.tar.bz2
gentoo-775c1ade4269bcf8a20e2fe6a11068177161c4de.zip
dev-python/reno: 2.7.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-2.7.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 5e857b1c2fd4..a7d349d36234 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1,2 +1,3 @@
DIST reno-2.2.1.tar.gz 56013 BLAKE2B db1966cf542e74e6842be64ee6a1a13cefcedab261bab951c9e39082ab0c0bf278e0b88bf3e876250f141c627a3625fb8038d190a6d58ee8d87054a86da38172 SHA512 278a7a43168f9467342f25c3eb8692e119cac285940b5d3f5a13f8f45acaffde962d2eeac720f2e5d824d085446fe5d660ef7082f95dd3c0360d594de5a65fb1
DIST reno-2.5.0.tar.gz 62819 BLAKE2B 1446d1289749df74d09c123af69dc6cacedb539b8387c73a1b0f0425651679e1332427afc482ba352e5176a76fcd6bfb65b31f731e0cfb2d137e23b739110b56 SHA512 ee7c44235dd1c3c253b426abbafd490658d642d56ebac5688dd1e3fca45451f26855f421b252c64f9e143bd67c8b08a9e4c6b79edc9c7341b26150a576458570
+DIST reno-2.7.0.tar.gz 65269 BLAKE2B f3ba0e33246d40f7f16739f367ad313ce440cd33c6f03de268f2e02293446e0d3a043287c36492d8cae44b65c682c09d13ab0e2c86beffc23a85184ef27a751b SHA512 daf32dd7c08f9f75a9a334db8aa9e8c4fdad266bd5e68a43a87920751cf57549fba7906da26dc6c8f79b97bfaf51ad481f80ce99168cd65cfbd62848cb3d0cab
diff --git a/dev-python/reno/reno-2.7.0.ebuild b/dev-python/reno/reno-2.7.0.ebuild
new file mode 100644
index 000000000000..3eb182c0edb0
--- /dev/null
+++ b/dev-python/reno/reno-2.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.python.org/pypi/reno"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"