summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-28 10:53:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-28 10:54:57 +0200
commit73d7896e2f6ce064b2d20f603484d2b06eab51a1 (patch)
tree6a39fe280127773d6cccfcb4807a7f302c2b2c24 /dev-python/reportlab/files
parentmedia-libs/libcdaudio: removed obsolete 0.99.12-r2 (diff)
downloadgentoo-73d7896e2f6ce064b2d20f603484d2b06eab51a1.tar.gz
gentoo-73d7896e2f6ce064b2d20f603484d2b06eab51a1.tar.bz2
gentoo-73d7896e2f6ce064b2d20f603484d2b06eab51a1.zip
dev-python/reportlab: Disable broken freetype2 finding logic
Closes: https://bugs.gentoo.org/836301 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reportlab/files')
-rw-r--r--dev-python/reportlab/files/reportlab-3.6.9-paths.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/reportlab/files/reportlab-3.6.9-paths.patch b/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
new file mode 100644
index 000000000000..e5ed7c43478d
--- /dev/null
+++ b/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
@@ -0,0 +1,21 @@
+Disable broken logic for finding freetype2 that hits symlink loops.
+
+diff -dupr reportlab-3.6.9.orig/setup.py reportlab-3.6.9/setup.py
+--- reportlab-3.6.9.orig/setup.py 2022-03-28 10:13:33.892516135 +0200
++++ reportlab-3.6.9/setup.py 2022-03-28 10:49:11.048573739 +0200
+@@ -737,13 +737,10 @@ def main():
+ else:
+ FT_LIB=FT_LIB_DIR=FT_INC_DIR=FT_MACROS=[]
+ else:
+- ftv, I, L = inc_lib_dirs('freetype')
+ FT_LIB=['freetype']
+- FT_LIB_DIR=L
+- FT_INC_DIR=I
++ FT_LIB_DIR=[]
++ FT_INC_DIR=['/usr/include/freetype2']
+ FT_MACROS = [('RENDERPM_FT',None)]
+- infoline('installing with freetype version %s' % ftv)
+- infoline('FT_LIB_DIR=%r FT_INC_DIR=%r' % (FT_LIB_DIR,FT_INC_DIR))
+ if not FT_LIB:
+ infoline('# installing without freetype no ttf, sorry!')
+ infoline('# You need to install a static library version of the freetype2 software')