summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-23 09:26:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-23 09:39:10 +0100
commit446158e3b1ba0b5d0cb084b7161deb11abc3ace1 (patch)
tree5c1bef1ff91799c41b62fdf92a1ccbf799ee8266 /dev-python/rfc3339-validator
parentxfce-extra/xfce4-systemload-plugin: Bump to 1.3.1 (diff)
downloadgentoo-446158e3b1ba0b5d0cb084b7161deb11abc3ace1.tar.gz
gentoo-446158e3b1ba0b5d0cb084b7161deb11abc3ace1.tar.bz2
gentoo-446158e3b1ba0b5d0cb084b7161deb11abc3ace1.zip
dev-python/rfc3339-validator: Bump to 0.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc3339-validator')
-rw-r--r--dev-python/rfc3339-validator/Manifest1
-rw-r--r--dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/rfc3339-validator/Manifest b/dev-python/rfc3339-validator/Manifest
index f99339080f97..fd72cb08590a 100644
--- a/dev-python/rfc3339-validator/Manifest
+++ b/dev-python/rfc3339-validator/Manifest
@@ -1 +1,2 @@
DIST rfc3339-validator-0.1.2.tar.gz 7429 BLAKE2B 9c08ae6ebe12af043ebad82a716e359f323f318d44e1f23a41759773e1927f90d6dde95566ca3c9463db6ffc9f2c3a31925ee4668f7fbe1defc78e09949ac391 SHA512 42164f8258025b056a6c5584c1c5e76f4c4fddead1a18199cd5b115a5a576d8863676d741e5e9a12bd4b41cbf55e722632a57dc3f76688ff0ad886615286c567
+DIST rfc3339-validator-0.1.3.tar.gz 7439 BLAKE2B 8991906720f3c7fe08edbc2994693b354338e70bb361e2ceebe168e8f8195a061c2cd716e365a7713c1a21658517e4f2028f9b619513408252a46ef589868c02 SHA512 d89679fb9fabcfa75cf3955744facb235201c0c3ccc4bcfd53b553c5403967226282b68e628d0dd74bb4abe553da6c3734912c63f3a5e16875e57a872c78231d
diff --git a/dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild b/dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild
new file mode 100644
index 000000000000..1b50d3cc8562
--- /dev/null
+++ b/dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A pure python RFC3339 validator"
+HOMEPAGE="https://github.com/naimetti/rfc3339-validator"
+SRC_URI="
+ https://github.com/naimetti/rfc3339-validator/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest