summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-02-15 11:16:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-02-15 13:35:52 +0100
commit69220602337b91c061687b87167fd13f4220594f (patch)
treea0de986b1d5c893ad434361c30426c1dcb9c6452 /dev-python/rosdistro/rosdistro-0.7.2.ebuild
parentdev-libs/libgit2-glib: 0.27.8 works with libgit2-0.28.1 (diff)
downloadgentoo-69220602337b91c061687b87167fd13f4220594f.tar.gz
gentoo-69220602337b91c061687b87167fd13f4220594f.tar.bz2
gentoo-69220602337b91c061687b87167fd13f4220594f.zip
dev-python/rosdistro: bump to 0.7.2
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/rosdistro/rosdistro-0.7.2.ebuild')
-rw-r--r--dev-python/rosdistro/rosdistro-0.7.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.7.2.ebuild b/dev-python/rosdistro/rosdistro-0.7.2.ebuild
new file mode 100644
index 000000000000..df8542c9a22e
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}