summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-04 15:38:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-04 15:58:55 +0200
commitdd4c7913837bd86f09d6e59d525674d40b187e4c (patch)
treecb3e76247951e5f69b53bc84259d1eac216cdbfa /dev-python/rq
parentdev-python/symengine: Remove old (py3.7) (diff)
downloadgentoo-dd4c7913837bd86f09d6e59d525674d40b187e4c.tar.gz
gentoo-dd4c7913837bd86f09d6e59d525674d40b187e4c.tar.bz2
gentoo-dd4c7913837bd86f09d6e59d525674d40b187e4c.zip
dev-python/rq: Remove old (py3.7)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.7.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 45423c8f4a9a..48accd1f2a56 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
-DIST rq-1.7.0.tar.gz 579373 BLAKE2B 835868a294478af07b9fa97fef14b0f2013abe125263efa15c4988eeaf564ee61ab2e8d68842c730a0f8b02a19a4d66f328828fb939a05b9d3b36996688192e0 SHA512 4027a8e1474cc350cf539ecf5734c2f851ef4e61bf0e106e44f359736f4f1ec4e690af97a119d12b1b7614b38ec4da286acff98b718ef604b5c367b3cc2af741
DIST rq-1.8.0.tar.gz 584251 BLAKE2B 3da1d4f1604a57e16e26c39643337fb8ab804089f783d6a7c44500f577a326cf4883835c996427e819896faad512b9a380ebfdcf67e865eec475d39321ecd2f5 SHA512 e8946b4454e67bc9ce0c69c302ba3bb6403654cce384904d64996766227ba8fdcbff834a8901a8fa09dcccebe8aba769d38daf228283f4142166fa5ea0f9a107
diff --git a/dev-python/rq/rq-1.7.0.ebuild b/dev-python/rq/rq-1.7.0.ebuild
deleted file mode 100644
index c7b91b7e21c2..000000000000
--- a/dev-python/rq/rq-1.7.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
-SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-distutils_enable_tests pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-python_test() {
- # Tests needing rqworker:
- # TestWorkerSubprocess::test_run_access_self, test_run_empty_queue, test_run_scheduled_access_self
- distutils_install_for_testing
- PATH="${BUILD_DIR}/test/scripts:${PATH}" pytest -vv || die "Testsuite failed under ${EPYTHON}"
-}