summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-27 21:09:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-27 21:09:40 +0200
commite8dc21026f218294053b952402fc1cd3498e479a (patch)
treea23af5ecf104fc8152c4d8979995d69ac5f5690d /dev-python/scipy
parentdev-python/pythran: Enable py3.13 (diff)
downloadgentoo-e8dc21026f218294053b952402fc1cd3498e479a.tar.gz
gentoo-e8dc21026f218294053b952402fc1cd3498e479a.tar.bz2
gentoo-e8dc21026f218294053b952402fc1cd3498e479a.zip
dev-python/scipy: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.14.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/scipy/scipy-1.14.0.ebuild b/dev-python/scipy/scipy-1.14.0.ebuild
index 6d117893f18d..8e3a14e3952c 100644
--- a/dev-python/scipy/scipy-1.14.0.ebuild
+++ b/dev-python/scipy/scipy-1.14.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
FORTRAN_NEEDED=fortran
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic fortran-2 distutils-r1
@@ -160,6 +160,12 @@ python_test() {
scipy/optimize/tests/test_hessian_update_strategy.py::TestHessianUpdateStrategy::test_initialize_catch_illegal
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # docstring formatting
+ scipy/misc/tests/test_doccer.py::test_decorator
+ )
+ ;;
esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1