summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-28 05:27:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-28 06:03:43 +0200
commitca9d11d10f350d3f132677767e3f14de8a2bee34 (patch)
treea269e202c1162ab85490431451889ef429645106 /dev-python/setuptools_scm_git_archive
parentdev-python/hypothesis: Bump to 6.48.1 (diff)
downloadgentoo-ca9d11d10f350d3f132677767e3f14de8a2bee34.tar.gz
gentoo-ca9d11d10f350d3f132677767e3f14de8a2bee34.tar.bz2
gentoo-ca9d11d10f350d3f132677767e3f14de8a2bee34.zip
dev-python/setuptools_scm_git_archive: Bump to 1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools_scm_git_archive')
-rw-r--r--dev-python/setuptools_scm_git_archive/Manifest1
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm_git_archive/Manifest b/dev-python/setuptools_scm_git_archive/Manifest
index 9775354ae235..dd9bd3c878cd 100644
--- a/dev-python/setuptools_scm_git_archive/Manifest
+++ b/dev-python/setuptools_scm_git_archive/Manifest
@@ -1,2 +1,3 @@
DIST setuptools_scm_git_archive-1.1.tar.gz 2584 BLAKE2B 7c7569a92300be966b5447b1ab6c30a982c837efdb7a125173f6014420d78cf28e0d8cb0f04c4349ce364219e1567bcbc2e13bd85cb7627d3bdbae9c7974385b SHA512 73783d60d33782fb18012e64685db6333a2dda1be41ce75e0cd74a81585d8ebb7c85f23371056a42974c93b2d4a0633338945cf2a2219b0ee2a21f063dad8809
DIST setuptools_scm_git_archive-1.2.gh.tar.gz 2648 BLAKE2B d2a6629fa1eb8c413def6c7cb192afb47299cd1ffce3692951fb6f90e9b6b4d0f4f2286486a5ae7e550c4659ed3ef7289746ec48be2bfe43c6c3d80143cc4e46 SHA512 980a7463dd7a53f71c8f9f1fde0f14927a6063bfae386b85d42a2909e05de42339a3770d5cf0c22981f17bbdec52febf7041fb54628f2d8321e46401ef0beccb
+DIST setuptools_scm_git_archive-1.3.gh.tar.gz 2556 BLAKE2B 338c02b9b377a165b4bcd29790e04b9e3215f2f892a681888760e5bdd2bc2a5c4970646fff42d652a6dde8557602af4dbde0decf5ac0f0605cbb55fc1f3ec085 SHA512 28146bef914f310590d29a1c3c2a97f1fe33d19d28eb7477983b6164d99d2e40e02afe541e5ef3ca8b7ff3297cc002d35da1f971d5d2183f2c5634c10b098476
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.3.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.3.ebuild
new file mode 100644
index 000000000000..394a9500b20f
--- /dev/null
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A setuptools_scm plugin for git archives"
+HOMEPAGE="
+ https://github.com/Changaco/setuptools_scm_git_archive/
+ https://pypi.org/project/setuptools-scm-git-archive/
+"
+SRC_URI="
+ https://github.com/Changaco/setuptools_scm_git_archive/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+
+python_test() {
+ epytest tests.py
+}