summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-07-13 14:09:20 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-07-13 14:09:36 +0200
commit25651d892a527302b6df400548d94dcffcc39613 (patch)
tree970f63507f01be00aa4ab9fe79c5413cecdeecd0 /dev-python/shapely
parentdev-python/google-api-python-client: Enable py3.13 (diff)
downloadgentoo-25651d892a527302b6df400548d94dcffcc39613.tar.gz
gentoo-25651d892a527302b6df400548d94dcffcc39613.tar.bz2
gentoo-25651d892a527302b6df400548d94dcffcc39613.zip
dev-python/shapely: bump to 2.0.5
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/shapely-2.0.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index ba0e94bdd1ce..2c307ca1ab79 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-2.0.4.gh.tar.gz 331588 BLAKE2B 4b7f8afa8e4358ed473c6172c340520a4cdf7ab76752c12a96070e88834c0b44fa87b0815fecbe337f012ca1d15bc3f38cb59ef23cf589d4e3e8f2ecbafb5660 SHA512 497bb6d1b3fbfc5758c167e984bb57f52746dae47d7d365e6f13e3879beced8194aea9119c287c8eadf2f74e038e2dbb07e906177f521fab195edcb4b7a9bdbb
+DIST shapely-2.0.5.gh.tar.gz 333029 BLAKE2B c618d0eddc53bf1b4f423b18eaeaf26ab7a1c1a8d32905e56a23387da9e4b4df610222bf58b85e095b0a0b9cece226fbae9fdf1e3689f71eb8d95d0b607b5109 SHA512 2f0364bb4480c971bd8a4f78ee1ac1cb014bf335e676b9531a092f30d522a9a34b670f96f3f92d7ea91a1da5043510f33a50fd4332ad5cdef1d19799122685a6
diff --git a/dev-python/shapely/shapely-2.0.5.ebuild b/dev-python/shapely/shapely-2.0.5.ebuild
new file mode 100644
index 000000000000..e28d47959a37
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ dev-python/numpy:=[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.11.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-c99.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf shapely || die
+ epytest --pyargs shapely
+}