summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-31 05:51:54 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-31 05:51:54 +0100
commit8f02b237460aac7066aa4a17df7c8f4e1b4031fe (patch)
treefd6a89ddfaa59014f45a8f4221bfd65a549c50af /dev-python/shapely
parentdev-python/pytz: Bump to 2025.1 (diff)
downloadgentoo-8f02b237460aac7066aa4a17df7c8f4e1b4031fe.tar.gz
gentoo-8f02b237460aac7066aa4a17df7c8f4e1b4031fe.tar.bz2
gentoo-8f02b237460aac7066aa4a17df7c8f4e1b4031fe.zip
dev-python/shapely: Bump to 2.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/shapely-2.0.7.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 105e057787b0..27507c9ce403 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-2.0.6.gh.tar.gz 333201 BLAKE2B 91e5f9552c6b0c33e87e91eebd848fb9a054d963e6e850d541ed65a4ad5b803d4959b1f8f89feb080824cd12299ca1a70ccfe17fb292469a0bd627257d06d1e4 SHA512 fedd3e43b7cdf011f19ab89bd27982520689c34d8c924b684441cefa9543a2feabbf856981f934b5935971fd805aae92fbe70e7414e4c9b5753f30eb750e03e0
+DIST shapely-2.0.7.gh.tar.gz 334359 BLAKE2B 3b12cf5d52595bfdfaa2b9b820a9d9e1bc95e18ca43accf5ec2dba2f30ceb9df90c359e360a51c9aa9a8c3121dcf39ad6e54c2a16793f61aa129dfef881a83ae SHA512 78ecb89d6a4fc880582f576bb4674b6a6ed28f863b65a218835badfb5bcb0b290ef87bbd3113b69d44ead7518643d0f8ecf2cd43f0e4b5b19b814dd8835a0107
diff --git a/dev-python/shapely/shapely-2.0.7.ebuild b/dev-python/shapely/shapely-2.0.7.ebuild
new file mode 100644
index 000000000000..e7c3d8a6883a
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ dev-python/numpy:=[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.11.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf shapely || die
+ epytest --pyargs shapely
+}