summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-25 23:40:17 +0100
committerSam James <sam@gentoo.org>2023-04-25 23:40:17 +0100
commit128d1cc021dd711e4962d955478af79dd49c0d98 (patch)
treecfddf192a6b5222b76f1cc8989aaa3ab971dd5eb /dev-python/sip
parentdev-ruby/json: drop obsolete sed (diff)
downloadgentoo-128d1cc021dd711e4962d955478af79dd49c0d98.tar.gz
gentoo-128d1cc021dd711e4962d955478af79dd49c0d98.tar.bz2
gentoo-128d1cc021dd711e4962d955478af79dd49c0d98.zip
dev-python/sip: add 6.7.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-6.7.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 0c5d9a1e495c..58865bd0f128 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,2 +1,3 @@
DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98 SHA512 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
DIST sip-6.7.8.tar.gz 1162921 BLAKE2B 3cc7107ad8c81240131ba96c43815b2a971bf109166a7a1bb3401cf5ed99e5d525599c0e7fcf7005c4b1d2194f9e7f386c4d58c10da712d4bd80d95e678f6804 SHA512 5d8965542c3fe821c95b2d2331d7f7df2ac9587a535f0b91f31223f4ee29f893ee73af42dc575abdff44a22a5b2ad98c6738211757595ae5a11f5a54fcea960d
+DIST sip-6.7.9.tar.gz 1163252 BLAKE2B 1f11edbd673703b42eeb16124b61ee92520a111e24de067506f10fec9682df12600124c1732c7b65690a9fa439cd9a233cc49b6740026a48561192e8ca7479d2 SHA512 bb9d0d0d92002b6fd33f7e8ebe8cd62456dacc16b5734b73760b1ba14fb9b1f2b9b6640b40196c6cf5f345e1afde48bdef39675c4d3480041771325d4cf3c233
diff --git a/dev-python/sip/sip-6.7.9.ebuild b/dev-python/sip/sip-6.7.9.ebuild
new file mode 100644
index 000000000000..29b9c88145e5
--- /dev/null
+++ b/dev-python/sip/sip-6.7.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="
+ https://www.riverbankcomputing.com/software/sip/
+ https://pypi.org/project/sip/
+"
+
+if [[ ${PV} == *_pre* ]]; then
+ MY_P=${PN}-${PV/_pre/.dev}
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit pypi
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+
+distutils_enable_sphinx doc --no-autodoc