summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 09:49:59 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 10:39:41 +0100
commit866087fa50159766ec635ba59f7ec403892b5970 (patch)
tree8f06b8f292f92708149097790d7e2c9a76b695ee /dev-python/slimit
parentmedia-video/subliminal: Call pytest directly (diff)
downloadgentoo-866087fa50159766ec635ba59f7ec403892b5970.tar.gz
gentoo-866087fa50159766ec635ba59f7ec403892b5970.tar.bz2
gentoo-866087fa50159766ec635ba59f7ec403892b5970.zip
dev-python/slimit: Set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/slimit')
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index c65e63cdd426..ca7d58331ceb 100644
--- a/dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=6
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( pypy3 python3_6 )
+
inherit distutils-r1
DESCRIPTION="A JavaScript minifier written in Python"
@@ -16,8 +18,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]