summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-13 04:50:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-13 05:12:18 +0200
commit459481a2821c2575d677ed3b6d2c2c727f13c2c0 (patch)
treefc50f41bf4f60875a2369c8d4315b5df17408b0d /dev-python/sphinx-autodoc-typehints
parentdev-python/pyzotero: Bump to 1.5.25 (diff)
downloadgentoo-459481a2821c2575d677ed3b6d2c2c727f13c2c0.tar.gz
gentoo-459481a2821c2575d677ed3b6d2c2c727f13c2c0.tar.bz2
gentoo-459481a2821c2575d677ed3b6d2c2c727f13c2c0.zip
dev-python/sphinx-autodoc-typehints: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index d824597d6c2a..9534bbb0d989 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,3 +1,4 @@
DIST sphinx_autodoc_typehints-2.2.3.tar.gz 40394 BLAKE2B eece3fd99898bf6c93561b0269a7cae2d9b5bd7868ef3d9cd61868b57b9435ef255731db7fdbde2cf05b1f1ed1c8864060fd15ad5b44bbd122f2c2d4fd264aeb SHA512 8a39129ae3e90703c7de8d25c7616256b4d203f6e3c6971f382265361236e7606fa16169e189ca47cd4f1dfdf27a98a16c7b92ce409e2431886e4dacd0159fcf
DIST sphinx_autodoc_typehints-2.3.0.tar.gz 40709 BLAKE2B ef1b606cf6a643f87271fb033bac4d06f83b2be9f73b765064757ff0c1dceb2124841b2f6bb674deb20e39a4d19386fea8c85f0cdb417eeb3d84da19e2bf609e SHA512 f4ee3e0eb51fd63d4cf31f2eed9b9d06cc2dc48a3f3427763e86dba8910ea02c9e31bd8d30e8d0b3494e71fb104d51904400ce96d71270e1e422f44a317de80a
DIST sphinx_autodoc_typehints-2.4.0.tar.gz 40568 BLAKE2B 7b56f034db042d027cb7ccfa3d1ef4f13fa22b22c536cebe42ec3f6da648c2d0578021b89fe4058326254a5900b6e6c9f5455cfcb9ea05cb1e7f6ec6adb0033d SHA512 eb3b11c4fcb1e12048662eec8179d877598f0ec2f34c15efcb4989a905c53442223f7265251f2be8afe5de151f09c342ccbc04f8392eb03bef41c98f1467ea30
+DIST sphinx_autodoc_typehints-2.4.1.tar.gz 40796 BLAKE2B ea49531017abd27ae8ff8066c49334047370b27d5c8f972518bf566f1d26b965534317da4bdda2a0f5ebaf4af80ccc4e4befa561fe1bb36e9e92d82cc3175b9c SHA512 fd1bceab209c0d4b65eaec96fbb4a061690fafaeb032c54274676c434fedb8dcfd6adbac0e43de8953578c4955520cc6aac2c4c135a98efe0d46c5ebf2d40a9c
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.1.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.1.ebuild
new file mode 100644
index 000000000000..e938bae4f916
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}