summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-11 09:36:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-11 09:42:24 +0100
commitcf62bb59194297a8005c9a49866fc5e8b688cb30 (patch)
tree250b3bdaead37aba62a313e8c474547c1d5162e8 /dev-python/sphinx-autodoc-typehints
parentprofiles: targets/desktop: Enable dev-qt/qtgui:5[accessibility] (diff)
downloadgentoo-cf62bb59194297a8005c9a49866fc5e8b688cb30.tar.gz
gentoo-cf62bb59194297a8005c9a49866fc5e8b688cb30.tar.bz2
gentoo-cf62bb59194297a8005c9a49866fc5e8b688cb30.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.25.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.25.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index efd6f95f3eef..7e669bf897ad 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -2,3 +2,4 @@ DIST sphinx_autodoc_typehints-1.24.0.tar.gz 36127 BLAKE2B 46f9eb12b7327dceaf623b
DIST sphinx_autodoc_typehints-1.24.1.tar.gz 36436 BLAKE2B be1de2ea15dd39f4adb30028849645b69a7f21aec7997a3fd633a5ba606a78e8f095b6a05bc66242003670adf5846c7b444ffd5eead39e0a7836f097ed0a3302 SHA512 d79f540939a8e669d0aaf238a213aade330ed46112231adae3ca822afdf5d12178247afc4a2a46938dc49aa73e556d0303db28e2ff48ebf6e26ddf71a7759c4e
DIST sphinx_autodoc_typehints-1.25.0.tar.gz 36871 BLAKE2B 1862bd2a0169a74ec342ce6ba1dc5604e84f828fc0d46f3f0d76832ec15d7e8ffad1dc3031fa6e088e82750e4b9ba70f913cba4896ad58e4dbb2a0cfac9da2ea SHA512 ad4410171fd4976fa939a4216769af03cddee136dbf6d02796e16bc577be4734ee80be899b7970a38bc4a581da7de7cba46903c2cd76255cef966e28827e2f72
DIST sphinx_autodoc_typehints-1.25.1.tar.gz 37019 BLAKE2B ef6a9c016c111ae8badced30d1c4b5a1691b2316ebc114ac51b229301670b204dd25ae10bb797a0ce3437dd8f2ae7c8be6a1aded39eed539e7bd0b2c04afbe1f SHA512 3e0aaca0cff346c8ba1b85709b6593a5c6ca1764f1ff56b0cb42ba95d001496de36c127b4d63a7d4f8a87e69beb3423898380c9cd6379b0205c16a91081eea93
+DIST sphinx_autodoc_typehints-1.25.2.tar.gz 37173 BLAKE2B cec43a8008e84cbc0cc8f1950d8c8b3aceec139f2c9b8de310620fbd7deab021ebc51caa0ec80421d821287c8f9c304102141eda9e1123496d710ce3d87590a7 SHA512 42d14b17e05c46d65fb363f6b640515e1847d1d1b13b9d4707c0e64002e01d974a4c8d06d90f938a149704641926b08755a8c9c1f84883b5841192c7330660a3
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.25.2.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.25.2.ebuild
new file mode 100644
index 000000000000..bfedfcb23611
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.25.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)