summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-13 08:33:34 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-13 10:37:31 +0100
commitd87228ce4f2fe11ef84ff1c1f33019f9d198496c (patch)
treeca0fa5c3f9ab198f0427a1be3a39c1b2efe25913 /dev-python/sphinx-gallery
parentdev-python/imageio: Bump to 2.10.4 (diff)
downloadgentoo-d87228ce4f2fe11ef84ff1c1f33019f9d198496c.tar.gz
gentoo-d87228ce4f2fe11ef84ff1c1f33019f9d198496c.tar.bz2
gentoo-d87228ce4f2fe11ef84ff1c1f33019f9d198496c.zip
dev-python/sphinx-gallery: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.10.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 2a7a42f2069e..15902e831e9b 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1 +1,2 @@
DIST sphinx-gallery-0.10.0.tar.gz 6544847 BLAKE2B c7ca0398b4a2c0090a9c6154b7aa068e05d4eef832a756693b07a23902d1c2e54bbcdb19c108a261555a12646b6fc5fa2314e0337ad8637c4d63173338189054 SHA512 9aa56966ec137f678187383440c0949fb1f91e88c66ad297efd48329627b9891c2d668a2472b071d9352cc22d717e41a5088884fa89a26707c5399dca7cc7237
+DIST sphinx-gallery-0.10.1.tar.gz 6546135 BLAKE2B 1f4ead74b848f28944820a77717183d845d1fba7459d11fa9bece16c5cd83742e012cce6906f8f5cd357e5c7db01107b6c7c32e2f7d5b7ce46dcd8d6a4b36e9c SHA512 da3b35907782846a58402fddf2a7f507eba76cd708725ff0ba097ec7bda6e9029252c9fb4df6d192aa7f64c6873465d4ff5e634b5c4cc6c4294e0d38c6db2f02
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.10.1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.10.1.ebuild
new file mode 100644
index 000000000000..01bce9304f3b
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.10.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+)