summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 08:55:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 09:31:13 +0200
commitb169598a7c8ab2ef15ee84d864bf26f6fbafae8c (patch)
tree9012c38cc5aa6a5021025209356e291fe104ea6e /dev-python/sphinx-notfound-page
parentdev-python/pocketlint: Bump to 0.24 (diff)
downloadgentoo-b169598a7c8ab2ef15ee84d864bf26f6fbafae8c.tar.gz
gentoo-b169598a7c8ab2ef15ee84d864bf26f6fbafae8c.tar.bz2
gentoo-b169598a7c8ab2ef15ee84d864bf26f6fbafae8c.zip
dev-python/sphinx-notfound-page: Bump to 0.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest1
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 161349ee007d..d09882719356 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1 +1,2 @@
+DIST sphinx-notfound-page-0.8.3.gh.tar.gz 59219 BLAKE2B cdb95906dba4d51aee88b220f094204575f2800737f160c7c028033002d41d2c793a91e1c61101f7c7c960ddf3b4d2ef83fbd285dd73ff5aed6c6c933b1fc1e7 SHA512 8d43ccfd3f83ff25b7a20ee3f5352489092dc641b4a794199c06c0971078a132a42b05c85588508ec38487f2915eedec98c2deac02d6c4576828be2fbc7f13b0
DIST sphinx-notfound-page-0.8.gh.tar.gz 57650 BLAKE2B e57634ba9a7faf81e6ee8d9b082d96742b580606f2e2fd559842049ba2e80bcb44bb6bd7a9c7eed6038e4c3ddb0416e32fceb4d47a72b8a600443e0020ff33d6 SHA512 eeb5b8da24ecb8f9814540a126f08204ae623705068608c2ee32a4f90303bdaab5f3934bdc36dd06dff047beb0225603f8cfc9b736769836385837047a36a674
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
new file mode 100644
index 000000000000..4d240a8aa65b
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)