summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 08:05:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 09:19:57 +0100
commitb725352a88fa1111018eb11e9c329acb703e6141 (patch)
tree85059b41fadb350a92207fd7f18c11a9b0ee18f3 /dev-python/sphinxcontrib-serializinghtml
parentdev-python/sphinxcontrib-applehelp: Bump to 1.0.8 (diff)
downloadgentoo-b725352a88fa1111018eb11e9c329acb703e6141.tar.gz
gentoo-b725352a88fa1111018eb11e9c329acb703e6141.tar.bz2
gentoo-b725352a88fa1111018eb11e9c329acb703e6141.zip
dev-python/sphinxcontrib-serializinghtml: Bump to 1.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-serializinghtml')
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest1
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index 46698430ef42..3c39df2891ad 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1 +1,2 @@
+DIST sphinxcontrib_serializinghtml-1.1.10.tar.gz 15592 BLAKE2B 35fd8458fbd300326b576aa798f9967a8bc4fe411a4d9ff0bfcf2f16f5945f9100480be7483fdafba1b4d11723f80b209e3cfd0e0f33dead1327105a11d0496b SHA512 e104817e8145cf99b3ca6cb548a7977d7f42dd442dc54e6de787c12722ea804e4a38bfe78bdb3d8ff5f71afc14bf4fbc84b15208d0c77790d377cf9ac91e4aa8
DIST sphinxcontrib_serializinghtml-1.1.9.tar.gz 15446 BLAKE2B 53d61209a043e7481c252e0a83f7e01e71ab2e385a28d78c9672b4a0d4fae2911ab4dff47dced09442a760872a7f63e04bae5916d9d7d96ff85c57b6f732eb7c SHA512 9e14527794a71120c1db9dc534383f3e56ee18241009aab2a04133351fc4dd56ee9ba242ad64be13faf44162e90e88109eb36a5692fb343f4bb28f43cda78bba
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild
new file mode 100644
index 000000000000..8c7f779f557d
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/
+ https://pypi.org/project/sphinxcontrib-serializinghtml/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest