summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 14:59:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 14:59:54 +0200
commit2776dcee438bbff77e918a62e3d1b3525109e18c (patch)
treeae43fa8312e465b6ca73b51c9282ad5133ded140 /dev-python/spotipy
parentdev-python/jsmin: fix variable order (diff)
downloadgentoo-2776dcee438bbff77e918a62e3d1b3525109e18c.tar.gz
gentoo-2776dcee438bbff77e918a62e3d1b3525109e18c.tar.bz2
gentoo-2776dcee438bbff77e918a62e3d1b3525109e18c.zip
dev-python/spotipy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/spotipy-2.23.0.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 5160ee4ef54c..dff2b528d321 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,2 +1 @@
-DIST spotipy-2.23.0.gh.tar.gz 112399 BLAKE2B 5510ce35624c561df61fffee78f211dfa91ff8d5b3dc15d37c96a51bf830e67aac9c6a0787c71715bee17a3ba91b84766c1ecec37d5775f2182617f2b74a2cb3 SHA512 52955fa3365d5153f19f60874ce8e96910ac8db783499e0e2ef2ab31127277844e24a045115dc522dd7b7535f7907de56da87e02a63b94ee7506b75c1e108e9b
DIST spotipy-2.24.0.gh.tar.gz 114822 BLAKE2B 0db73d723c1cb3818d68cfa90fd8077c6d6eb82b16f24e087907091d74644b86431aa93ea5ed9a842ec674c16f67cddc5be17a3b6cfcb92d0c01aa8bd3d1529f SHA512 9860119f078ff894a9b27bb4d51cd7b469c2cea4981757338d8c3f1c6c8a1c0bbb3b79622820486c07f0b86ce4e26f9329635b51fc976c4cee43122b9a0209ff
diff --git a/dev-python/spotipy/spotipy-2.23.0.ebuild b/dev-python/spotipy/spotipy-2.23.0.ebuild
deleted file mode 100644
index a01f9a212115..000000000000
--- a/dev-python/spotipy/spotipy-2.23.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight Python library for the Spotify Web API"
-HOMEPAGE="
- https://spotipy.readthedocs.io/
- https://github.com/spotipy-dev/spotipy/
- https://pypi.org/project/spotipy/
-"
-SRC_URI="
- https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-KEYWORDS="amd64 ~x86"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- dev-python/redis[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
-)
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use examples && dodoc -r examples
-}