summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-11 22:13:55 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-13 11:31:19 +0300
commitb17b16911ca6cb6388ebb4b25d1821d915bfb693 (patch)
tree2b24cfc6bcf8f8ee54dd5b31bed4891d7fec7c42 /dev-python/spyder/files
parentdev-python/spyder: version bump 4.1.2 (diff)
downloadgentoo-b17b16911ca6cb6388ebb4b25d1821d915bfb693.tar.gz
gentoo-b17b16911ca6cb6388ebb4b25d1821d915bfb693.tar.bz2
gentoo-b17b16911ca6cb6388ebb4b25d1821d915bfb693.zip
dev-python/spyder: clean up old
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/15313 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder/files')
-rw-r--r--dev-python/spyder/files/spyder-4.1.1-build.patch35
-rw-r--r--dev-python/spyder/files/spyder-4.1.1-py3-only.patch55
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/spyder/files/spyder-4.1.1-build.patch b/dev-python/spyder/files/spyder-4.1.1-build.patch
deleted file mode 100644
index 7463550fc165..000000000000
--- a/dev-python/spyder/files/spyder-4.1.1-build.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -r -U3 spyder-4.0.0b1.orig/setup.py spyder-4.0.0b1/setup.py
---- spyder-4.0.0b1.orig/setup.py 2018-08-12 04:35:49.000000000 +0700
-+++ spyder-4.0.0b1/setup.py 2018-08-14 20:25:32.827148778 +0700
-@@ -112,21 +107,6 @@
-
-
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
-- def run(self):
-- install_data.run(self)
-- if sys.platform.startswith('linux'):
-- try:
-- subprocess.call(['update-desktop-database'])
-- except:
-- print("ERROR: unable to update desktop database",
-- file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
- # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
-@@ -210,8 +190,7 @@
- 'Intended Audience :: Science/Research',
- 'Intended Audience :: Developers',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=CMDCLASS)
-+ 'Topic :: Software Development :: Widget Sets'])
-
-
- #==============================================================================
diff --git a/dev-python/spyder/files/spyder-4.1.1-py3-only.patch b/dev-python/spyder/files/spyder-4.1.1-py3-only.patch
deleted file mode 100644
index afdc92a1e122..000000000000
--- a/dev-python/spyder/files/spyder-4.1.1-py3-only.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 2d5d58b..4adc952 100644
---- a/setup.py
-+++ b/setup.py
-@@ -31,13 +31,6 @@ import shutil
- from distutils.core import setup
- from distutils.command.install_data import install_data
-
--
--#==============================================================================
--# Check for Python 3
--#==============================================================================
--PY3 = sys.version_info[0] == 3
--
--
- #==============================================================================
- # Minimal Python version sanity check
- # Taken from the notebook setup.py -- Modified BSD License
-@@ -87,13 +80,8 @@ def get_subpackages(name):
- def get_data_files():
- """Return data_files in a platform dependent manner"""
- if sys.platform.startswith('linux'):
-- if PY3:
-- data_files = [('share/applications', ['scripts/spyder3.desktop']),
-- ('share/icons', ['img_src/spyder3.png']),
-- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
-- else:
-- data_files = [('share/applications', ['scripts/spyder.desktop']),
-- ('share/icons', ['img_src/spyder.png'])]
-+ data_files = [('share/applications', ['scripts/spyder.desktop']),
-+ ('share/icons', ['img_src/spyder.png'])]
- elif os.name == 'nt':
- data_files = [('scripts', ['img_src/spyder.ico',
- 'img_src/spyder_reset.ico'])]
-@@ -131,9 +119,7 @@ CMDCLASS = {'install_data': MyInstallData}
- # See spyder-ide/spyder#1158.
- SCRIPTS = ['%s_win_post_install.py' % NAME]
-
--if PY3 and sys.platform.startswith('linux'):
-- SCRIPTS.append('spyder3')
--else:
-+if sys.platform.startswith('linux'):
- SCRIPTS.append('spyder')
-
- if os.name == 'nt':
-@@ -269,8 +255,7 @@ if 'setuptools' in sys.modules:
-
- setup_args['entry_points'] = {
- 'gui_scripts': [
-- '{} = spyder.app.start:main'.format(
-- 'spyder3' if PY3 else 'spyder')
-+ '{} = spyder.app.start:main'.format('spyder')
- ]
- }
-