summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-10 11:28:05 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-10 11:28:05 +0200
commit4c1ac2fe65f195915e92d0503b253419276982ca (patch)
tree272f6536d955a403b5bb6f1439fcabf47fd24e65 /dev-python/spyder
parentapp-text/crqt-ng: Add the Qt6 version (diff)
downloadgentoo-4c1ac2fe65f195915e92d0503b253419276982ca.tar.gz
gentoo-4c1ac2fe65f195915e92d0503b253419276982ca.tar.bz2
gentoo-4c1ac2fe65f195915e92d0503b253419276982ca.zip
dev-python/spyder: drop (broken) test support
This is not working anyway and it is now blocking clean-up of dev-python/pytest-lazy-fixture. Upstream has made it clear they don't care about downstream distribution packaging so I strongly doubt they will take any pull request to migrate away from pytest-lazy-fixture and I don't feel like arguing with them (again). Closes: https://bugs.gentoo.org/939425 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/spyder-5.5.6.ebuild44
-rw-r--r--dev-python/spyder/spyder-6.0.0.ebuild44
2 files changed, 44 insertions, 44 deletions
diff --git a/dev-python/spyder/spyder-5.5.6.ebuild b/dev-python/spyder/spyder-5.5.6.ebuild
index fde20eed16f9..adff8e0dbaa0 100644
--- a/dev-python/spyder/spyder-5.5.6.ebuild
+++ b/dev-python/spyder/spyder-5.5.6.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 optfeature virtualx xdg
+inherit distutils-r1 optfeature xdg #virtualx
# Commit of documentation to fetch
DOCS_PV="6951e02799fc7cd1f29456f1d93cfdcb570dad27"
@@ -64,23 +64,23 @@ RDEPEND="
>=dev-python/watchdog-0.10.3[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/matplotlib[tk,${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-order[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP},pyside2,pyqt5]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- )"
+# BDEPEND="
+# test? (
+# dev-python/cython[${PYTHON_USEDEP}]
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/matplotlib[tk,${PYTHON_USEDEP}]
+# dev-python/pandas[${PYTHON_USEDEP}]
+# dev-python/pillow[${PYTHON_USEDEP}]
+# dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-order[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+# dev-python/pytest-timeout[${PYTHON_USEDEP}]
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/QtPy[${PYTHON_USEDEP},pyside2,pyqt5]
+# dev-python/scipy[${PYTHON_USEDEP}]
+# dev-python/sympy[${PYTHON_USEDEP}]
+# )"
# Based on the courtesy of Arfrever
# This patch removes a call to update-desktop-database during build
@@ -100,7 +100,7 @@ DOCS=(
"RELEASE.md"
)
-distutils_enable_tests pytest
+# distutils_enable_tests pytest
# TODO: Package sphinx-design
# distutils_enable_sphinx docs/doc \
# dev-python/sphinx-panels \
@@ -164,9 +164,9 @@ python_prepare_all() {
# Calling pytest directly somehow passes the pytest arguments to spyder
# causing an invalid argument error
-python_test() {
- virtx "${EPYTHON}" runtests.py
-}
+# python_test() {
+# virtx "${EPYTHON}" runtests.py
+# }
pkg_postinst() {
xdg_pkg_postinst
diff --git a/dev-python/spyder/spyder-6.0.0.ebuild b/dev-python/spyder/spyder-6.0.0.ebuild
index b4c6b1eb1a62..14599f036609 100644
--- a/dev-python/spyder/spyder-6.0.0.ebuild
+++ b/dev-python/spyder/spyder-6.0.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 optfeature virtualx xdg
+inherit distutils-r1 optfeature xdg #virtualx
# Commit of documentation to fetch
DOCS_PV="6951e02799fc7cd1f29456f1d93cfdcb570dad27"
@@ -70,23 +70,23 @@ RDEPEND="
>=dev-python/yarl-1.9.4[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/matplotlib[tk,${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-order[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- )"
+# BDEPEND="
+# test? (
+# dev-python/cython[${PYTHON_USEDEP}]
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/matplotlib[tk,${PYTHON_USEDEP}]
+# dev-python/pandas[${PYTHON_USEDEP}]
+# dev-python/pillow[${PYTHON_USEDEP}]
+# dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-order[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+# dev-python/pytest-timeout[${PYTHON_USEDEP}]
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/QtPy[${PYTHON_USEDEP}]
+# dev-python/scipy[${PYTHON_USEDEP}]
+# dev-python/sympy[${PYTHON_USEDEP}]
+# )"
# Based on the courtesy of Arfrever
# This patch removes a call to update-desktop-database during build
@@ -106,7 +106,7 @@ DOCS=(
"RELEASE.md"
)
-distutils_enable_tests pytest
+# distutils_enable_tests pytest
# TODO: Package sphinx-design
# distutils_enable_sphinx docs/doc \
# dev-python/sphinx-panels \
@@ -166,9 +166,9 @@ python_prepare_all() {
# Calling pytest directly somehow passes the pytest arguments to spyder
# causing an invalid argument error
-python_test() {
- virtx "${EPYTHON}" runtests.py
-}
+# python_test() {
+# virtx "${EPYTHON}" runtests.py
+# }
pkg_postinst() {
xdg_pkg_postinst