summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 14:54:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 15:05:42 +0300
commit9f3142fb22ab549c0c88d526fe045cb1d427e91a (patch)
tree3e7ec345d4f5c9a62647a785e5c2625757a3f748 /dev-python/sqlalchemy
parentdev-python/whoosh: enable py3.11 (diff)
downloadgentoo-9f3142fb22ab549c0c88d526fe045cb1d427e91a.tar.gz
gentoo-9f3142fb22ab549c0c88d526fe045cb1d427e91a.tar.bz2
gentoo-9f3142fb22ab549c0c88d526fe045cb1d427e91a.zip
dev-python/sqlalchemy: enable py3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild
index f6015bde3b33..6e431959e507 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
PYTHON_REQ_USE="sqlite?"
inherit distutils-r1 optfeature
@@ -52,6 +52,10 @@ python_test() {
[[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
)
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # https://github.com/sqlalchemy/sqlalchemy/issues/8019
+ test/engine/test_logging.py::TransactionContextLoggingTest::test_log_messages_have_correct_metadata_echo
+ )
if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
EPYTEST_DESELECT+=(
test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution