summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-27 09:13:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-27 09:18:32 +0200
commit10a12833c5ff22646cafce073bff86fefd99ec6e (patch)
tree8aa9e49ebc3fd540c9648bc0c3b43e8e05a399f9 /dev-python/sqlglot
parentdev-python/google-auth: Bump to 2.23.1 (diff)
downloadgentoo-10a12833c5ff22646cafce073bff86fefd99ec6e.tar.gz
gentoo-10a12833c5ff22646cafce073bff86fefd99ec6e.tar.bz2
gentoo-10a12833c5ff22646cafce073bff86fefd99ec6e.zip
dev-python/sqlglot: Bump to 18.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-18.8.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 9ea294667cd2..5b646143dba7 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -2,3 +2,4 @@ DIST sqlglot-18.5.0.tar.gz 8634825 BLAKE2B aaf1854e87fea1ba598c45b12ef142bd825fc
DIST sqlglot-18.5.1.tar.gz 8636732 BLAKE2B a1cb6e9d5cf91178996681e527f211c31c9a0f0d6bf5036ed7d824d13475f4efbd109df9eb34bc35f0e9f7e443d3ebb2634cf041bdf0e716c9d73d78f679dcbf SHA512 8bf57c14ae374c3367aecc91b239d39df3d4fbd8a6b29837cf48eae0f5116ca5c181c71ded134a771a9512430c97c9dc6f45ae9578a9110eb5729721628178c5
DIST sqlglot-18.6.0.tar.gz 8655209 BLAKE2B cd7ba46e06cb2b537db7912d674f3d43026d111e49ba190ea2f62c9340ade1983b754437473d1d66bf2eebb18060aa8bf79082e6ffcf8144ab8c87aac36deaf4 SHA512 70a6c2d1fcaa18197d15e096690bf6beb16fbe13ea0db45a2224ab7aaf05ab8a4efae8be68fb1463c12741dc13e8e57a8ea2e75e2065c7ea3ab52a2cb6ea7d7e
DIST sqlglot-18.7.0.tar.gz 8757398 BLAKE2B aeb6c671c00968654ef9b772df05c2277cd1a789251e13832bd63faf966bea5ec1395a65dc7db9695533f90438b86b8487119caa4f94e3a72a54978af4379dab SHA512 4f233696b595115ff2cb173533342b2bfbfb9f291f3a69f70d3c60a049b91d1d24e7365e42e096d8bc9cfdce595a006302a450c65cfb1296d052b8d59b27cc98
+DIST sqlglot-18.8.0.tar.gz 8764753 BLAKE2B f1a01a1dc939a53476d396c66e74b1ec0550f557ef2eac1bec5001229964e2838655d361612b20527fae0f8112ccc940295cd0d92e83d5ba1f272f4d9372374b SHA512 3e98ff8ad4e6061c41d90b33c7982b46b8e06680d14e989923077d61ac93d390df64df6ff182a1c87911979dd84ac493275bbc091bcdcc9a1dfce2a4091c7fa7
diff --git a/dev-python/sqlglot/sqlglot-18.8.0.ebuild b/dev-python/sqlglot/sqlglot-18.8.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}