summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-03 22:57:05 +0300
committerMichał Górny <mgorny@gentoo.org>2023-08-04 04:41:55 +0200
commitc3343eeb0c891b996546eae2f6137e25fc1c5914 (patch)
tree89dd7ec3c067ccd8b62ae0532a99c6cd9968653f /dev-python/sqlglot
parentdev-python/gsd: Bump to 3.1.1 (diff)
downloadgentoo-c3343eeb0c891b996546eae2f6137e25fc1c5914.tar.gz
gentoo-c3343eeb0c891b996546eae2f6137e25fc1c5914.tar.bz2
gentoo-c3343eeb0c891b996546eae2f6137e25fc1c5914.zip
dev-python/sqlglot: add 17.9.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.9.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 98d5c01041ef..9173b86e2f04 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,2 +1,3 @@
DIST sqlglot-17.8.6.tar.gz 8382262 BLAKE2B 70c14c50cbd673122e0560d41b26076ff2d22c75d611cb751ae3df9e5f98e8392440144edcb38bde272f5a95ac85a48cb85358a75dd9b53a1b72e8133964c15c SHA512 839d10ef3d589dd258a5297dc21846e0aafd145892e4c2650aa12ea16064da1dceacd9e1f9cbd6f804b8590435db61066cb01a92b3a1d88a69b1aa8dffaeb15b
DIST sqlglot-17.9.0.tar.gz 8382270 BLAKE2B 86bd687906e7e2fca631021a0d77fbe91beb931ead70dd6d7b5a7255a5302412bede8b1e5abdc4e8ffb610640c3e3597ee1d78cbf6fe3d4e76947572bbec26ad SHA512 52b1eeece3854b9a0ed839a0f0f08af572d9e445a84d241af481bb104b49cba5a5af6b02a671343d69b4c2233f9e3f4c355969307e86d91544d32a94fdf4a5b4
+DIST sqlglot-17.9.1.tar.gz 8389281 BLAKE2B 97c1642a42940344cffb9a6c53db44d4850d0d4b029dde16f202288515d40cfb3a405813893140041bd19c30ed9dfa9d1ab104e0a61a6ccefa140df26fa86eb9 SHA512 925b56cf0bb84a58416b32af33ed37c30ca93d56244ab3cd6f72276dbeb448a85e3b1919c9bca77f3d0c51b9de70f0b98afc666067b1377ede8e52dea3d71267
diff --git a/dev-python/sqlglot/sqlglot-17.9.1.ebuild b/dev-python/sqlglot/sqlglot-17.9.1.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}