summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-25 05:55:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-25 06:03:21 +0200
commitff30db1212f86588fb9d56d45bd2bbdf8e1145ad (patch)
treea203ac8c8b2adddf80b38ad46ea5575a1a936fad /dev-python/starlette
parentdev-python/python-multipart: Bump to 0.0.14 (diff)
downloadgentoo-ff30db1212f86588fb9d56d45bd2bbdf8e1145ad.tar.gz
gentoo-ff30db1212f86588fb9d56d45bd2bbdf8e1145ad.tar.bz2
gentoo-ff30db1212f86588fb9d56d45bd2bbdf8e1145ad.zip
dev-python/starlette: Bump to 0.41.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/starlette')
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.41.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 637603ff3b85..0bb594b41166 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,2 +1,3 @@
DIST starlette-0.39.2.gh.tar.gz 2573134 BLAKE2B e6cd3bd3e2c2fac96d8b145ffae3a680d775a7668d9baf4db09ab81036985c8c0f5cdc6505f6db56f51126013118568c75d6f0dd6c28ea330baf575a5ff7c004 SHA512 2e81e61451136802449baafd152bf6db9cdad9a111713efb16ccef419aeb9a99b004167cd890509bad613df12d300cb5531197867c594c2b755220a1dae7bf14
DIST starlette-0.41.0.gh.tar.gz 2573744 BLAKE2B 34e96fdb97eaf9fd2de66587c5fdd877d572269ada720f7d0e9f7d3befb4e500210236d84bb2d5eb4de49e7bc005485085671d47f3885c55eed6032ef98ebda7 SHA512 9640a6117c252bdad7f065c374e09eda56f1c2c2bd2d38748000651aeb4ce92f519c9598b8dec8579810adfcd7a58173ccfdf4e2c1953f2609aca520c5b45551
+DIST starlette-0.41.1.gh.tar.gz 2573805 BLAKE2B dd883e9247cf60ca98250c59640215e065513684321a8e7dceabc2681ad092939c50462ada8c5e50a6c6f7a46cc75439e164daaab045e0e218b9185ec885b21c SHA512 1b02527826534404c4f9a7a6f26d16a618d72e11f1a1bd5e7188928a76e5070c7f6ede488226247782c948948002e4d1556cabb41ff208a8d229f2eea2d61342
diff --git a/dev-python/starlette/starlette-0.41.1.ebuild b/dev-python/starlette/starlette-0.41.1.ebuild
new file mode 100644
index 000000000000..a7637ab5fa89
--- /dev/null
+++ b/dev-python/starlette/starlette-0.41.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/python-multipart-0.0.13[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+: ${EPYTEST_TIMEOUT:-180}
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p anyio
+}