summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-28 06:12:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-28 06:27:50 +0200
commita0f70ae6948ba31801f8e25f2b0fcc0236830d21 (patch)
tree6a4622ead5e4e868284a9bad2490692f9c16f723 /dev-python/structlog
parentdev-python/hypercorn: Bump to 0.17.2 (diff)
downloadgentoo-a0f70ae6948ba31801f8e25f2b0fcc0236830d21.tar.gz
gentoo-a0f70ae6948ba31801f8e25f2b0fcc0236830d21.tar.bz2
gentoo-a0f70ae6948ba31801f8e25f2b0fcc0236830d21.zip
dev-python/structlog: Bump to 24.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/structlog')
-rw-r--r--dev-python/structlog/Manifest1
-rw-r--r--dev-python/structlog/structlog-24.2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/structlog/Manifest b/dev-python/structlog/Manifest
index 7b8a184f39dd..adae347c2fd9 100644
--- a/dev-python/structlog/Manifest
+++ b/dev-python/structlog/Manifest
@@ -1 +1,2 @@
DIST structlog-24.1.0.tar.gz 1340948 BLAKE2B ad92e145a8a45f7aaf08f26e637b4de42e56d3c5931f022b4524126a5650f30a8e7185ce87bd7e2c91fd48853dfc94585c13184bded1792d2c50153625379c3b SHA512 bb64d8d4ab9afe7482bdaafc3efae833426a256575ff99d013ae1438f3d5d0261842e598028ea644824577f579c5c4704108ce597de0a2eab5ffc1615a609ea6
+DIST structlog-24.2.0.tar.gz 1346958 BLAKE2B d47e78ec3c55048460a32a860ac2e5ebed9e49f546277e562104fec66e73e25702b61c2b8a250a9729c0c774e7c0c1492733957a9a551328267533187e63972e SHA512 df470f292bbf1de6a4a509f034c3bccb87e21afc31cf31a0ef998485a4b69e5bf6ec46d90236d556c876aa96e5a3dcb323d0bfe9bd8ac63a47b527a747af73c8
diff --git a/dev-python/structlog/structlog-24.2.0.ebuild b/dev-python/structlog/structlog-24.2.0.ebuild
new file mode 100644
index 000000000000..a523146cc838
--- /dev/null
+++ b/dev-python/structlog/structlog-24.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Logging for Python"
+HOMEPAGE="
+ https://github.com/hynek/structlog/
+ https://pypi.org/project/structlog/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest