summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-17 04:56:18 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-17 05:22:20 +0100
commiteb284b48aba6cbda604da6160bd2d4781ee59f8a (patch)
tree5f121d4861de63e2e00b769b81a8749ac771b8f6 /dev-python/structlog
parentdev-python/oslo-concurrency: Bump to 7.0.0 (diff)
downloadgentoo-eb284b48aba6cbda604da6160bd2d4781ee59f8a.tar.gz
gentoo-eb284b48aba6cbda604da6160bd2d4781ee59f8a.tar.bz2
gentoo-eb284b48aba6cbda604da6160bd2d4781ee59f8a.zip
dev-python/structlog: Bump to 25.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/structlog')
-rw-r--r--dev-python/structlog/Manifest1
-rw-r--r--dev-python/structlog/structlog-25.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/structlog/Manifest b/dev-python/structlog/Manifest
index e3465d5f8617..0d454e783b70 100644
--- a/dev-python/structlog/Manifest
+++ b/dev-python/structlog/Manifest
@@ -1 +1,2 @@
DIST structlog-24.4.0.tar.gz 1348634 BLAKE2B 29b35ad7471e6e681c86363880397869b5a149ff06bd1e5c68c7587ff2da6663ded7d278788b77fbc6d945cadda89073dbb3f43fbd4b0e21a71380a6d361593a SHA512 0dedb73caa9cd8f288267f129b9b61ae7db542fec1c92a38d785e1606d56a1272fb9fb5dd23c04a8fd0ce0a3c41f430d51230475bde4eab1919998187fbe680b
+DIST structlog-25.1.0.tar.gz 1364973 BLAKE2B 6e7237eb87e0e8669a42bdee214d9a9d7095363b42fcf4f86be8d50e6d320bf9199d08de13e138cd520c42dadb68cfd676dbe8f6792a892fe1f79738d1c711a6 SHA512 190722bbd71355fce1dc6842ca3b358a2de99b4823e1175e52205e719b8164e3d5d16f55307e93bb3b4b03d9f655ae01a8ccb89cd3a5908d6d5cf3fa63e0f03a
diff --git a/dev-python/structlog/structlog-25.1.0.ebuild b/dev-python/structlog/structlog-25.1.0.ebuild
new file mode 100644
index 000000000000..38ba2b097d70
--- /dev/null
+++ b/dev-python/structlog/structlog-25.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Logging for Python"
+HOMEPAGE="
+ https://github.com/hynek/structlog/
+ https://pypi.org/project/structlog/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest