summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 16:00:52 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 16:05:44 +0100
commit3dc800ff3af15fada8130302b8cb49e042f8afa7 (patch)
tree3dd8ca2ee4378a5bd7779fcc46c54f1fb45ddd2b /dev-python/subprocess-tee
parentdev-python/pytest-verbose-parametrize: BDEPEND on setuptools-git (diff)
downloadgentoo-3dc800ff3af15fada8130302b8cb49e042f8afa7.tar.gz
gentoo-3dc800ff3af15fada8130302b8cb49e042f8afa7.tar.bz2
gentoo-3dc800ff3af15fada8130302b8cb49e042f8afa7.zip
dev-python/subprocess-tee: initial import
Builds, tests and installs fine on all implementations listed in PYTHON_COMPAT. Needs a bit more work because it installs its own test suite as a submodule, though. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/subprocess-tee')
-rw-r--r--dev-python/subprocess-tee/Manifest1
-rw-r--r--dev-python/subprocess-tee/metadata.xml13
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/subprocess-tee/Manifest b/dev-python/subprocess-tee/Manifest
new file mode 100644
index 000000000000..cb2773b8f7ab
--- /dev/null
+++ b/dev-python/subprocess-tee/Manifest
@@ -0,0 +1 @@
+DIST subprocess-tee-0.3.2.tar.gz 14975 BLAKE2B 3198832f4c8bbf90e83038e39017cff1efc61ede84aded8220214e388a088777bdb861c044cddbf4b07c7b3172f8164e8bbf82b33de68d1fefea0f81bbacdfc9 SHA512 e681abc27623a3e05031bc05dc15e34f82c9cb544cd16742855411a9edb11fe8e38f9d11f8e651681d04081f121a47c38ebd172d70d282c8110a62699ef687d6
diff --git a/dev-python/subprocess-tee/metadata.xml b/dev-python/subprocess-tee/metadata.xml
new file mode 100644
index 000000000000..228103910a31
--- /dev/null
+++ b/dev-python/subprocess-tee/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pycontribs/subprocess-tee</remote-id>
+ <remote-id type="pypi">subprocess-tee</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild
new file mode 100644
index 000000000000..2b37121c39f3
--- /dev/null
+++ b/dev-python/subprocess-tee/subprocess-tee-0.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="subprocess.run replacement with tee(1)-like output"
+HOMEPAGE="https://github.com/pycontribs/subprocess-tee"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/enrich[${PYTHON_USEDEP}]
+ ' python3_{8,9})
+ )"
+
+distutils_enable_tests pytest
+
+# dev-python/{,en}rich ebuilds do not support python3_10 yet
+# We test fine (modulo some deprecation warnings) against 3.10 under tox, though.
+python_test() {
+ if [[ ${EPYTHON} == "python3.10" ]]; then
+ ewarn "Skipping tests for ${EPYTHON} due to missing dependencies"
+ return 0
+ fi
+ distutils-r1_python_test
+}
+
+# TODO: do not install subprocess_tee.test