summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-22 17:10:53 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-22 23:32:31 -0400
commit3cc50b65321183ff06b82cd477ecc9a3402bd880 (patch)
treec0a474ca04f5807c220c20ca89e19ab77be5fb3c /dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
parentdev-python/krb5: Bump to 0.6.0 (diff)
downloadgentoo-3cc50b65321183ff06b82cd477ecc9a3402bd880.tar.gz
gentoo-3cc50b65321183ff06b82cd477ecc9a3402bd880.tar.bz2
gentoo-3cc50b65321183ff06b82cd477ecc9a3402bd880.zip
dev-python/thriftpy2: remove LTO workaround
It was fixed upstream in 0.5.0 based on our report. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-python/thriftpy2/thriftpy2-0.5.2.ebuild')
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.5.2.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild b/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
index b045d0f08da7..96c5e972bc59 100644
--- a/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
+++ b/dev-python/thriftpy2/thriftpy2-0.5.2.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 flag-o-matic pypi
+inherit distutils-r1 pypi
DESCRIPTION="Pure python approach of Apache Thrift"
HOMEPAGE="
@@ -34,18 +34,6 @@ BDEPEND="
distutils_enable_tests pytest
-src_compile() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/857105
- # https://github.com/Thriftpy/thriftpy2/issues/246
- #
- # Don't trust this to LTO
- append-flags -fno-strict-aliasing
- filter-lto
-
- distutils-r1_src_compile
-}
-
python_test() {
local EPYTEST_DESELECT=(
tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception