summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-24 14:23:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-24 14:46:03 +0200
commitf7550f6f7a762e8e472f6b6027b22e1eea4390ed (patch)
treee2deee87adf6116ddb8a31f1fe6fa405bc68911c /dev-python/tifffile
parentdev-python/sentry-sdk: Bump to 2.11.0 (diff)
downloadgentoo-f7550f6f7a762e8e472f6b6027b22e1eea4390ed.tar.gz
gentoo-f7550f6f7a762e8e472f6b6027b22e1eea4390ed.tar.bz2
gentoo-f7550f6f7a762e8e472f6b6027b22e1eea4390ed.zip
dev-python/tifffile: Bump to 2024.7.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2024.7.24.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 1ec6af26e5cb..6d5096d34cd5 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,2 +1,3 @@
DIST tifffile-2024.7.2.gh.tar.gz 349770 BLAKE2B c722f23857310826568f54bffa4f071c8018c6d17ee810dad423f6e9ad80ee99f888bf9282e8cc53d710ba5052c69136e8385aa7ac7e9052346fa766cfdc1747 SHA512 11efbda0f20428fbff4863f52425021de9303be8ad76051c7daf5921f1282a88655872c98dcb2530ea354b1f2833509b3b98b82d035dc8bbae4a4d2da0ef8d47
DIST tifffile-2024.7.21.gh.tar.gz 350351 BLAKE2B 665060211809e51ef38f233d300524e1af79f02c966c3409269280fd6b383022d3b2a87b6c581f7703d31f93b279f77779dc63d2bffbd2f95dd55f954f7f8bc4 SHA512 5d41d389e7ba706bf2fa6ed224878a2af4aa4ba98c9ec4f3b975e32019e894869bbdd8615619dfd7910a9600f05703f14371981be281e9f9144cb240e4be26c0
+DIST tifffile-2024.7.24.gh.tar.gz 350866 BLAKE2B f978e93c308bd7813d2cb6d0c48686ff75cdf8702aaa6888a4a9b50b3dcd60edb15f8a1404b8468aa38e4fefc0161a49448bfd57a5d7719ac7a8372a5a72dc00 SHA512 ad2ca4412a11f3afa175811651f85b2b9ff3da3d1382633ca9b50530fe976050e56abf7c2333660e07230f826fb8af152df355ee211a2409408be6084137647b
diff --git a/dev-python/tifffile/tifffile-2024.7.24.ebuild b/dev-python/tifffile/tifffile-2024.7.24.ebuild
new file mode 100644
index 000000000000..190a5b9ccada
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.7.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}