summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-28 17:30:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-28 17:30:23 +0300
commita00395ced2aef9a8f15b76347426f2d11608644a (patch)
tree8b06634f4d049cc9071aa1cecdddb02f0fbd3da5 /dev-python/tox
parentdev-python/tox: Stabilize 4.4.11 x86, #904803 (diff)
downloadgentoo-a00395ced2aef9a8f15b76347426f2d11608644a.tar.gz
gentoo-a00395ced2aef9a8f15b76347426f2d11608644a.tar.bz2
gentoo-a00395ced2aef9a8f15b76347426f2d11608644a.zip
dev-python/tox: drop 4.4.6, 4.4.7, 4.4.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest3
-rw-r--r--dev-python/tox/tox-4.4.6.ebuild95
-rw-r--r--dev-python/tox/tox-4.4.7.ebuild90
-rw-r--r--dev-python/tox/tox-4.4.8.ebuild80
4 files changed, 0 insertions, 268 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 676e200f1ec1..b42ab31091f2 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,8 +1,5 @@
DIST tox-3.28.0.gh.tar.gz 309472 BLAKE2B 9896411426f6aebb3efa468c01696ecc5f17ec3e67825672d0efc74c1b1468bc8b8d9c14b6177c181750ba4b9a5e77d616068dd83e21f5641acfc8e2a271cc1f SHA512 64816754e6800661bb564c5c7d21c4139522d540a04fafe3c4591d596072d48d1cbe0ee2abee9c8faf3d5007774f5371431b5a7a8f49912bc879c7b168aab2ca
DIST tox-4.4.11.tar.gz 170069 BLAKE2B e2e560462cbb6081c27ff0268fa8a6b0239caac0b237bbd66709ce578996800728346bd22491cfade85d7d04d2c00a769179efd4a160decfd97f94fcedc7ed24 SHA512 7a0a39ac55482aa423368fee6621aef9d95c58afd5d38975bcaf67edfebdc817aacc33efdd1f0f459953c25bceed73c6ef03ce789aea7f82f3ab1dcc6546118c
DIST tox-4.4.12.tar.gz 170092 BLAKE2B 03a1d1ddd8c36c88e3b30f464df9b20d516ef282664b138f64a969195901d353d678d9c1e4ca2e61d73fed891b942105dbeef97e281e219fe2110ba92517adf2 SHA512 896ecef178b0625246ffe4ab3a9a0c03650eb78633fa92706e93475d6589ac29d65bbf91b9ecfacfa8154739eefd463aeb1252be68998cdffddc270a4f89edd0
-DIST tox-4.4.6.gh.tar.gz 304337 BLAKE2B 2c157fe5febf1eb131d767ade87484880201bb37fa65a579abb9780d755d570f216b8f865dd2dd8dbb3a3af01be78133f9ac0b73a3166dfc2b9cd99f6547498a SHA512 403bca89228d665182bfbb61550dfd9e9fb4ce4a5592472d50cd38e3f264c806fa15bbdccc020a720ad69885d9be54a1f074f6d87549cbe2b523e53d870358dc
-DIST tox-4.4.7.tar.gz 168261 BLAKE2B 276842bb82d01c9e3b66f633e79974790b7d1852f831ab954172ddc1d3c50c861a39e959fb0a990a7102a1cc0840238ef3ac84c7b41f9f45ce502b1245e21988 SHA512 58989ecc0a555ee225614d9b7a718b22f6dd1555a0209a0c1428259fbfc7d336a58753fbfa85f1b9aa160c8489587999425437e71f9d4728631d5cd5b50ca159
-DIST tox-4.4.8.tar.gz 169460 BLAKE2B 5353c489d5051b23b39c23fcbad1455556c23572b504ba241f9942a01f5ae5f1459d3b3837680aa9631dcd8a081c0f3b8acce1b18e85daeab3e2084ec966e451 SHA512 a6e5ceb19ebf1adcfe5cd093a2710da88c1552f2129211175990b7b7fb6b53716fdccd7592e9c6696bf13ce584443c9a266e40ed50953999883fa1a68ea6aec6
DIST tox-4.5.0.tar.gz 170132 BLAKE2B fbde455d90791b81ba8fb47b2c00a0c931e56bef39749a324e16b12f2955441371c74983d3c77b98f04f5a0e95ddf78678ff96fc2f99f42a87bd0058a3aefb98 SHA512 79e3fd7308a3da0df5859437ff7842a343578a98211a6a936f72caec857dbdb5e0bd4b80fd68a3a48fb0891d4608875ccc1b09d7127416aaa7109a8aa314979c
DIST tox-4.5.1.tar.gz 170137 BLAKE2B 38ab00eb577e66211db0ecf8931087a8c5a14f8219eb7ebecb7be9938221d1c680edc09a38a5c72b9ec63825d4cbb2d4fd9157a52aed8cdb0d22a1c1bbb70cba SHA512 75d495d6dba134c3fe537fc190c1f428ff188ee67c346911c02ee151a8369425b22956eea52be5d434735e1590edce57b3487d5f4b277022bf8cfe8bf4660cf8
diff --git a/dev-python/tox/tox-4.4.6.ebuild b/dev-python/tox/tox-4.4.6.ebuild
deleted file mode 100644
index bb9be16f77c3..000000000000
--- a/dev-python/tox/tox-4.4.6.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=${P/_}
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="
- https://tox.readthedocs.io/
- https://github.com/tox-dev/tox/
- https://pypi.org/project/tox/
-"
-SRC_URI="
- https://github.com/tox-dev/tox/archive/${PV/_}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/cachetools-5.3[${PYTHON_USEDEP}]
- >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.9[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
- >=dev-python/pluggy-1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-api-1.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
- test? (
- >=dev-python/build-0.10[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
- >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
- >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/time-machine-2.9[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-src_prepare() {
- # the minimal bounds in tox are entirely meaningless and new packaging
- # breaks setuptools
- sed -i -e '/packaging/s:>=[0-9]\+::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # devpi_process is not packaged, and has lots of dependencies
- cat > "${T}"/devpi_process.py <<-EOF || die
- def IndexServer(*args, **kwargs): raise NotImplementedError()
- EOF
-
- local -x PYTHONPATH=${T}:${PYTHONPATH}
- local EPYTEST_DESELECT=(
- # Internet
- tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
- )
- local EPYTEST_IGNORE=(
- # requires devpi*
- tests/test_provision.py
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
- )
-
- epytest
-}
diff --git a/dev-python/tox/tox-4.4.7.ebuild b/dev-python/tox/tox-4.4.7.ebuild
deleted file mode 100644
index 2248781df596..000000000000
--- a/dev-python/tox/tox-4.4.7.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="
- https://tox.readthedocs.io/
- https://github.com/tox-dev/tox/
- https://pypi.org/project/tox/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/cachetools-5.3[${PYTHON_USEDEP}]
- >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.9[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
- >=dev-python/pluggy-1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-api-1.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
- test? (
- >=dev-python/build-0.10[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
- >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
- >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/time-machine-2.9[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # the minimal bounds in tox are entirely meaningless and new packaging
- # breaks setuptools
- sed -i -e '/packaging/s:>=[0-9]\+::' pyproject.toml || die
- # workaround https://github.com/agronholm/exceptiongroup/pull/59
- [[ -f tox.ini ]] && die "Remove the hack, please"
- > tox.ini || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # devpi_process is not packaged, and has lots of dependencies
- cat > "${T}"/devpi_process.py <<-EOF || die
- def IndexServer(*args, **kwargs): raise NotImplementedError()
- EOF
-
- local -x PYTHONPATH=${T}:${PYTHONPATH}
- local EPYTEST_DESELECT=(
- # Internet
- tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
- )
- local EPYTEST_IGNORE=(
- # requires devpi*
- tests/test_provision.py
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
- )
-
- epytest
-}
diff --git a/dev-python/tox/tox-4.4.8.ebuild b/dev-python/tox/tox-4.4.8.ebuild
deleted file mode 100644
index 48e88e0cf5d2..000000000000
--- a/dev-python/tox/tox-4.4.8.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="
- https://tox.readthedocs.io/
- https://github.com/tox-dev/tox/
- https://pypi.org/project/tox/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/cachetools-5.3[${PYTHON_USEDEP}]
- >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.10[${PYTHON_USEDEP}]
- >=dev-python/packaging-23[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-3.1.1[${PYTHON_USEDEP}]
- >=dev-python/pluggy-1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-api-1.5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- >=dev-python/virtualenv-20.21[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
- test? (
- >=dev-python/build-0.10[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
- >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-3.2.1[${PYTHON_USEDEP}]
- >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/time-machine-2.9[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # devpi_process is not packaged, and has lots of dependencies
- cat > "${T}"/devpi_process.py <<-EOF || die
- def IndexServer(*args, **kwargs): raise NotImplementedError()
- EOF
-
- local -x PYTHONPATH=${T}:${PYTHONPATH}
- local EPYTEST_DESELECT=(
- # Internet
- tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
- )
- local EPYTEST_IGNORE=(
- # requires devpi*
- tests/test_provision.py
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[constraints-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[explicit+requirements-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_indirect-True-True]'
- 'tests/tox_env/python/pip/test_pip_install.py::test_constrain_package_deps[requirements_constraints_indirect-True-True]'
- )
-
- epytest
-}