summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 15:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 15:04:57 +0200
commit7a5a67fff0fd603724c161fcd77eb0fc3a5dbb9f (patch)
treecbe7c9d15e6fe78d21ad2cc4cae6774c8c84a3ef /dev-python/tqdm
parentdev-python/pytest-skip-markers: Mark ALLARCHES (diff)
downloadgentoo-7a5a67fff0fd603724c161fcd77eb0fc3a5dbb9f.tar.gz
gentoo-7a5a67fff0fd603724c161fcd77eb0fc3a5dbb9f.tar.bz2
gentoo-7a5a67fff0fd603724c161fcd77eb0fc3a5dbb9f.zip
dev-python/tqdm: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/files/tqdm-4.66.4-py313.patch43
-rw-r--r--dev-python/tqdm/tqdm-4.66.4.ebuild50
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 7578be764996..e26838b80b21 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1 @@
-DIST tqdm-4.66.4.tar.gz 169392 BLAKE2B 6d8e3e9775d93d9c064289b8a830b4f541a753a48044ec65fcee9c8d158d423e362d06c3404efce67de28fab2c3f1fb3d8aaa0fdec33b4d040ad1f2aec97fde2 SHA512 fdafa64784564f7f400f29ffa75ba564a3c9bc6d935a1ccd82260d4a1f4431792a9dae2d5c6ed69cc265f078f674081589a040d47b8745a500870d27670feadc
DIST tqdm-4.66.5.tar.gz 169504 BLAKE2B 9868bcfb4f3fc22aedfbb848d383055ef6ef9795982cd7877e620dba5391ffee369c375b27555c302d1fc6fb27ddacf8d3874daeffa62e5e8699e1124fbf96af SHA512 8e2c35f02fe365063a325d8a1d3e525870d522fab465e1a86764b8716ff32c039db463fe5e74a5f080ced40851d49b1e4273126074d62f14ed1935a96e0afb8a
diff --git a/dev-python/tqdm/files/tqdm-4.66.4-py313.patch b/dev-python/tqdm/files/tqdm-4.66.4-py313.patch
deleted file mode 100644
index 9417ce91a55a..000000000000
--- a/dev-python/tqdm/files/tqdm-4.66.4-py313.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From eafdd306861f531c443885048f0abdaa6bc45f8e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 27 Jun 2024 18:30:55 +0200
-Subject: [PATCH] cli: Fix docstring processing with Python 3.13+
-
-Fix docstring processing code to reindent the docstrings if using Python
-3.13 or newer. Starting with this version, all docstrings are
-automatically dedented by Python, which causes the regular expression to
-fail to match.
-
-Fixes #1585
----
- tqdm/cli.py | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/tqdm/cli.py b/tqdm/cli.py
-index 7284f28..1bbce6d 100644
---- a/tqdm/cli.py
-+++ b/tqdm/cli.py
-@@ -4,6 +4,7 @@ Module version for monitoring CLI pipes (`... | python -m tqdm | ...`).
- import logging
- import re
- import sys
-+import textwrap
- from ast import literal_eval as numeric
-
- from .std import TqdmKeyError, TqdmTypeError, tqdm
-@@ -177,7 +178,11 @@ def main(fp=sys.stderr, argv=None):
- logging.basicConfig(level=getattr(logging, logLevel),
- format="%(levelname)s:%(module)s:%(lineno)d:%(message)s")
-
-- d = tqdm.__doc__ + CLI_EXTRA_DOC
-+ d = tqdm.__doc__
-+ if sys.version_info >= (3, 13):
-+ # Python 3.13+ automatically dedents docstrings
-+ d = textwrap.indent(d, " ")
-+ d += CLI_EXTRA_DOC
-
- opt_types = dict(RE_OPTS.findall(d))
- # opt_types['delim'] = 'chr'
---
-2.45.2
-
diff --git a/dev-python/tqdm/tqdm-4.66.4.ebuild b/dev-python/tqdm/tqdm-4.66.4.ebuild
deleted file mode 100644
index 2dca9f1051c0..000000000000
--- a/dev-python/tqdm/tqdm-4.66.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit bash-completion-r1 distutils-r1 pypi
-
-DESCRIPTION="Add a progress meter to your loops in a second"
-HOMEPAGE="
- https://github.com/tqdm/tqdm/
- https://pypi.org/project/tqdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-IUSE="examples"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/tqdm/tqdm/pull/1594
- "${FILESDIR}/${P}-py313.patch"
-)
-
-EPYTEST_IGNORE=(
- # Skip unpredictable performance tests
- tests/tests_perf.py
-)
-
-python_install_all() {
- doman tqdm/tqdm.1
- newbashcomp tqdm/completion.sh tqdm
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}