summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-05-25 16:17:32 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-05-25 16:20:54 -0500
commit9e8f09bb1a8303e079169766ea55130b9758a56d (patch)
tree1852747ab930afb3233b5cae4480d18653d1b22d /dev-python/txtorcon
parentdev-python/spake2: new package, add 0.8 (diff)
downloadgentoo-9e8f09bb1a8303e079169766ea55130b9758a56d.tar.gz
gentoo-9e8f09bb1a8303e079169766ea55130b9758a56d.tar.bz2
gentoo-9e8f09bb1a8303e079169766ea55130b9758a56d.zip
dev-python/txtorcon: new package, add 23.5.0
Revision: - enable testsuite - verified that the package installs cleanly for 3.10 and 3.11 Bug: https://bugs.gentoo.org/907117 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/txtorcon')
-rw-r--r--dev-python/txtorcon/Manifest1
-rw-r--r--dev-python/txtorcon/metadata.xml13
-rw-r--r--dev-python/txtorcon/txtorcon-23.5.0.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/txtorcon/Manifest b/dev-python/txtorcon/Manifest
new file mode 100644
index 000000000000..021c0fbb9e57
--- /dev/null
+++ b/dev-python/txtorcon/Manifest
@@ -0,0 +1 @@
+DIST txtorcon-23.5.0.gh.tar.gz 394188 BLAKE2B ee63d2815a9b697aa37d27697ef6085dc91e750ba0cad854c8610eed7afcfec9b50cf5aead24f75676e2b0ee39167c50fbebc43a51911a3ebe17eb784b18d31e SHA512 33610c043084273f5dc06b797fff11bb0fccaae14229dbd07286e13e40ebc199594f6e52c64b87e4060e37bcb44bd90ccf7ff7217d923fdb33a581fb95144d56
diff --git a/dev-python/txtorcon/metadata.xml b/dev-python/txtorcon/metadata.xml
new file mode 100644
index 000000000000..41f36acb77d0
--- /dev/null
+++ b/dev-python/txtorcon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">txtorcon</remote-id>
+ <remote-id type="github">meejah/txtorcon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/txtorcon/txtorcon-23.5.0.ebuild b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
new file mode 100644
index 000000000000..e55600a84380
--- /dev/null
+++ b/dev-python/txtorcon/txtorcon-23.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking abstractions"
+HOMEPAGE="https://txtorcon.readthedocs.org https://pypi.org/project/txtorcon/"
+SRC_URI="https://github.com/meejah/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ sys-process/lsof
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest