summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-25 22:06:38 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-25 22:47:14 +0200
commita447aff39145997824d9feed3294c600e5161efd (patch)
tree218b7dc61f6a9514262185b2868877c2e297128d /dev-python/typish/typish-1.9.3.ebuild
parentapp-arch/pxz: fix for musl (diff)
downloadgentoo-a447aff39145997824d9feed3294c600e5161efd.tar.gz
gentoo-a447aff39145997824d9feed3294c600e5161efd.tar.bz2
gentoo-a447aff39145997824d9feed3294c600e5161efd.zip
dev-python/typish: new package, add 1.9.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/typish/typish-1.9.3.ebuild')
-rw-r--r--dev-python/typish/typish-1.9.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/typish/typish-1.9.3.ebuild b/dev-python/typish/typish-1.9.3.ebuild
new file mode 100644
index 000000000000..a81608fc7bd2
--- /dev/null
+++ b/dev-python/typish/typish-1.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Functionality for types"
+HOMEPAGE="https://pypi.org/project/typish/
+ https://github.com/ramonhagenaars/typish"
+SRC_URI="
+ https://github.com/ramonhagenaars/typish/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/nptyping[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest